Showing results for 
Search instead for 
Did you mean: 


Adept I

RX 550 bad performance opengl


  I have a Gigabyte RX 550 2GB DDR5 , I use X-plane a flight simulator which is an Opengl based game.

  Have terrible performance in opengl for both under Windows 10 and Linux. Though i am a bit bottle necked due to CPU / RAM , the new upgrade is planned for next year , hence i tried the other flight simulators which are DX11 -  DCS World / il2 and both these perform like 40-50 fps which is actually good.

X-plane under windows will give me not more than 15-18 fps and under linux it's worst where it actually chokes the system and with similar fps. Today morning i decided to upgrade to Adrelaine 18.10 from 18.5 and wow i was getting 9 fps.

Using Linux 18.4 AMDGPU-Pro and on windows 10 - 18.10 (will be going back to 18.5).

Hence for linux i had to use the open source Mesa / Gallium which give me around 10-15 fps more which is quite good, But X-plane developers said they don't support open source Mesa / Gallium and  i am stuck with this problem.

X-plane will be going with Vulkan starting early next year .

I hope the technical staff of the GPU drivers development team take into consideration as what the problem is with Opengl in the drivers.

The other test i carried out was using American Truck Simulator which is again availlable for Directx and Opengl and supports both windows / Linux. The same issue if tried under AMD Adrenlain under windows using Opengl (8-10 fps less)  and under Mesa (linux ) better performance.

Need anymore info then please let me.

My config :

AMD X4 810

8 GB DDR3 1333Mhz

Gigabyte RX 550 2GB DDR5

Windows 10 / Lubuntu 18.04



4 Replies
Journeyman III

Did you make sure it is the GPU that is bottlenecking you? When playing, run Windows Task Manager in the background and have a look if your GPU is actually utilized properly, if the VRAM is sufficient and such. Maybe that can tell us something.



The thing is it performs much better under Linux Open Source Mesa / Gallium. But the X-plane dev has asked me not to use the Mesa as they are not supporting it.  VRAM / RAM maybe bottle necking but then why would the Mesa drivers not show performance issues.

  The bottle necks are CPU / RAM which i will be upgrading later, but my problem is under windows. Hence i carried out the other tests like testing ATS / DCS / il2 / Dirt Rally.

I will check what you suggest and get back in a couple of days.




If you want to let AMD know about this, this is a USER TO USER support forum, meaning users like you helping other users. Nobody from driver development here. For AMD to know about the issue, file an ISSUE REPORT the link is on the driver download page and in preferences in Radeon Settings on your computer. Please do this as the more people that complain them more seriously they take the issue. I have read many reports of these issues but it is likely not many are actually being reported properly.



Thanks, i will report it to AMD support.