cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

strifept
Journeyman III

rx 480 - WoW: Legion

Hello.

Just today i bought myself a Sapphire nitro 4GB version of the 480 and i'm getting huge fps issues on WoW: Legion. The issue is 100% the graphics card, as i was having better FPS with an R9 270x, which makes no sense.

my specs are:

Windows 10 64-bit

CPU: Intel I5 4460 @3.20 ghz
GPU: RX 480 Nitro 4GB OC
4 Gb ram

Crimson driver version 16.8.3 (recommended from the amd app)

I've tried:
Rolling back to older driver versions.
Fully reinstalling the drivers using DDU.

Any help is appreciated.

Edit: I just noticed my GPU is running at half the GHZ, so that might be it. Can someone help me?

Edit 2: Added a dxdiag

0 Kudos
15 Replies
derrickgott007
Miniboss

Re: rx 480 - WoW: Legion

Update your driver to the newest one for the RX480..... 16.8.3   You are a few updates behind

0 Kudos
strifept
Journeyman III

Re: rx 480 - WoW: Legion

Already did, did not work.

0 Kudos
redhen256
Adept II

Re: rx 480 - WoW: Legion

What are your temperatures in game? have you set up Wattman to allow for more power to the card when its needed? How low is your fps?

0 Kudos
strifept
Journeyman III

Re: rx 480 - WoW: Legion

arround 60-70 never more.

I'm getting 35 ish in Dalaran (populated city) and a bit more outside, like 55-ish. When particle intensive efects show up my fps's literally drop to like 5

0 Kudos
redhen256
Adept II

Re: rx 480 - WoW: Legion

My friend with a brand new 1070 gets like 35 in stormwind so that is not too too bad. going down to 5 fps however is another story. Are you using 2 monitors or one? I noticed on mine when I switched between windowed full screen and just full screen, there was a difference in fps and choppiness. 

0 Kudos
strifept
Journeyman III

Re: rx 480 - WoW: Legion

Only one, and it happens with certain effects only, but i believe that might be a game related issue, multiple people have been reporting it.

0 Kudos
dcmbalthazar
Journeyman III

Re: rx 480 - WoW: Legion

My problem is similar, but my hardware is different.

Windows 10 64Bits

AMD A10 7850

Gigabyte gigabyte f2a78m-d3h

16 GB RAM DDR3 2133 Corsair (2x8)

running on a SSD disc

I formatted my PC and installed latest version of crimson, and tried to change wattman configuration.

I need help too.

thanks

0 Kudos
redhen256
Adept II

Re: rx 480 - WoW: Legion

That could def be. I changed my AA settings yesterday and it brought up my fps by a significant portion.

0 Kudos
dcmbalthazar
Journeyman III

Re: rx 480 - WoW: Legion

I even turned it off and in my case it  doesn't make significant difference...

0 Kudos