Showing results for 
Search instead for 
Did you mean: 


Journeyman III

RX 480 4gb monitor hanging

Hello everyone, I have a very frustraiting problem with my RX 480 that I can't seem to find a solution to. I searched alot but I am not sure maybe I am searching with the wrong words - nothing comes exactly as my problem so I decided to describe it here and I realy hope someone can help.

I am using my PC with a 144Hz Acer monitor in order to be able to play games at higher frame rates. In order for this to work I have to use the Display Port of the video card. Ever since the 18-th version of the AMD drivers my DP (Display Port) is not working. Its not entirely unfunctional but operating with it is imposible. When I turn on my PC my monitor starts to turn off - it shows like I don't have signal, circles through all the ports and goes in sleep mode. After 5-10 seconds it turns on. I see my desktop and 5-10 seconds later it turns off again, circles the other ports and goes to sleep. And that is going on forever - goes to sleep, 5-10 sec, turns on, 5-10 sec, goes to sleep and so on.

Now - I DON'T have the problem on my HDMI port, I don't have it when I am on bios or when in safe mode - only on normal working windows and only on the DP port.

I tried reinstalling fiew different versions of the AMD Drivers. Not working.

I tried reinstalling the older 17.12.1 version. The problem is still there now only it is not that severe. It makes only 2-3 or 5-6 cicles of shitching on and off and then its ok for some time. The bad thing is that then it starts happening at random times and usualy when I play a game.

I have made a short video of what is happening you can check it here - RX480 drivers problem - YouTube

Here are my system specs:

Video: Sapphire Radeon RX 480 4GB,

CPU: Intel Core i7-8700,

Ram: 8 GB,

Motherboard: ASROCK Z370m Pro4,

PSU: Cooler Master 500W,

I have 2 x HDD and one SSD,

Windows 10 64 bit

My monitor is Acer XZ271 27-inch 144hz with FreeSync.

I will be very very thankful if anyone have any idea why this is happening or if they had the same problem and fixed it. Thank you in advance.

P.S. - Sorry for my bad english, as you can see form the video it is not my native language