Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Recently installed HD 7750 with 6 monitor support. Worked at first, had to disconnect a monitor to move on stand, now 1 won't display

I run multiple monitors for work. I had been using 4, but got to where I was having to split them, so decided to buy a new card that would support 6. I bought a Radeon HD 7750 (Visiontech I believe) that has 6 mini displayport outs. It's not a powerhouse card, but I didn't need that, just needed to support 6 monitors. Not doing hi-res gaming or anything. I already had 2 active miniDP to HDMI adapters from my old card, so I used those, along with 4 active miniDP to HDMI cables. When I first booted it up, everything was perfect, all 6 displayed great. But I have 1 monitor I use for monitoring security, and it's got a small line across it, doesn't matter for that but is annoying for working on, and I put it in the wrong spot, and wanted to swap sides, so I disconnected that monitor and the one on the other side, plugged them back in, and only 4 monitors came on: the 2 with active adapters, and 2 of the others. If I disconnected one, the other would come on, so I know the monitor is good, the cable is good, and the output is good, but it's responding like I was trying to connect more than 2 legacy monitors or passive cables, but all 6 are active. 4 hours of swapping cables, reboots, updating software and drivers, changing display settings (clone, extend, etc) finally got a 5th one to show, but the 6th one still isn't. In display settings, it is shown small and greyed out, disconnected. If I say duplicate or extend, it says "The display settings could not be saved. Please try a different combination of display settings." Catalyst Control Center in "Creating and Arranging Desktops" shows the 5 that are displaying in the configuration, and all 6 below where you select a display to modify, but one is shown as disabled. If I enable it, it will come on but another one of the 4 with active cables will go out. The 2 with active adapters are the only 2 that are consistently on, so I can't think of anything other than there's something wonky going on with those 4 cables not playing nicely, even though it worked perfectly at first. Any thoughts or ideas would be greatly appreciated.