cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

gojevic
Journeyman III

Radeon W5500 New PC no display

PCPartPicker Part List

Type Item Price

CPUAMD Ryzen 9 3900X 3.8 GHz 12-Core Processor
Motherboard\*MSI B550-A PRO ATX AM4 Motherboard$139.99 @ Walmart
MemoryG.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 CL16 Memory$143.80 @ MemoryC
StorageKingston A2000 250 GB M.2-2280 NVME Solid State Drive$40.49 @ Staples
StorageWestern Digital Blue 1 TB 2.5" Solid State Drive$114.99 @ Western Digital
Video CardAMD Radeon Pro W5500 8 GB Video Card
CaseThermaltake Versa H21 ATX Mid Tower Case
Power Supply\*EVGA B5 550 W 80+ Bronze Certified Fully Modular ATX Power Supply$79.94 @ ModMyMods
Prices include shipping, taxes, rebates, and discounts
Total$519.21
*Lowest price parts chosen from parametric criteria
Generated by PCPartPicker 2020-11-26 16:48 EST-0500

 

 

Looking for help solving this ongoing issue:

 

I cannot get my PC to display to any of my monitors using the display port cord from the GPU to monitor, display port from MOBO to monitor, or hdmi from MOBO to monitor. MOBO goes through all debug lights and turns off until BOOT but I can't get my screen to show.

List anything you've done in attempt to diagnose or fix the problem.

This is the 3rd mobo I have tried and 2nd CPU. Each time, same issue. My very first GPU was this:

https://www.amd.com/en/products/professional-graphics/radeon-pro-wx-5100

But it is not on the MSI compatible list for this MOBO. My very first MOBO with this build was the MSI B550 Gaming Plus with the same problem, but I switched to the A pro thinking I might try my luck there. Current part list is what I am running. I am now using this GPU:

https://www.amd.com/en/products/professional-graphics/radeon-pro-w5500

I tested my display port cord that came with my monitor:

https://www.amazon.com/Viotek-GN34CW-34-Inch-Ultrawide-Professional/dp/B07HZ499J4/ref=sr_1_1_sspa?dc...

On my room mates pc and we noticed something very interesting. With only the display port plugged in, his screen remained black as well until he hit enter, then it logged into windows and displayed his screen but never showed his BIOS or login screen. He has no password and normally hits enter to get into windows.

I have read online that display ports have priorty issue, but I have no way of installing my BIOS that I know of without getting an initial display. These radeon GPUs have all 4 ports as display ports, and my CPU does not have a built in GPU :( to run off the mobo for the initial BIOS install.

I feel like I have tried everything, from testing my ram sticks (when removed the RAM debug stays on, so that works) to replacing my MOBO 3 times. No luck. New GPU that is listed as compatible with MSI, no luck.

When system turns on fans will spin, lights will turn on (debug light ends on BOOT), but never gets to display. Please help!

0 Likes
10 Replies
korinogaro
Adept III

Re: Radeon W5500 New PC no display

Can't you borrow GPU from your friend?

0 Likes
Chacbolay
Journeyman III

Re: Radeon W5500 New PC no display

Hi, I have the same problem, did you solve it? 

AMD changed my video card, but on both my computers it doesn't work.

0 Likes
vialli100
Elite

Re: Radeon W5500 New PC no display

I know this may seem silly..

When i got my new monitor, I couldn't get it to display over DP..

I had to go into the monitor OSD setting and set it to DP not auto..

I was thinking maybe a bios update to the latest, as you have bios update via USB..

AMD Ryzen 7 3700x, Sapphire RX580 Nitro 8gb, Asus TUF Gaming x570 Plus, 32gb Corsair Vengeance 3000mhz, Samsung 970 EVO Plus 1tb NVME, Samsung 960 EVO 500gb NVME, WD Black 1tb, Crucial 525gb MX300 SSD, Sandisk Ultra 500gb SSD... Lian Li Galahad AIO 240mm, Seasonic X850 PSU.
0 Likes
elstaci
MVP

Re: Radeon W5500 New PC no display

@fsadough  AMD Moderator expert on Professional GPU card might be able to assist both of you guys.

0 Likes
fsadough
Moderator
Moderator

Re: Radeon W5500 New PC no display

  • The issue described by gojevic is from Nov 2020, not sure he still has the problem or not.
  • vialli100's issue is related to gaming GPU => file a support ticket
elstaci
MVP

Re: Radeon W5500 New PC no display

@fsadough  I didn't notice the date of the thread but there was one reply recently concerning the OP issue from @Chacbolay but he doesn't mention if he has the same GPU card or a Consumer GPU card.

0 Likes
fsadough
Moderator
Moderator

Re: Radeon W5500 New PC no display

@Chacbolay 

Please provide details to your system and GPU.

0 Likes
vialli100
Elite

Re: Radeon W5500 New PC no display

It's ok as I don't have an issue..

I was replying to the post and didn't notice the date..

AMD Ryzen 7 3700x, Sapphire RX580 Nitro 8gb, Asus TUF Gaming x570 Plus, 32gb Corsair Vengeance 3000mhz, Samsung 970 EVO Plus 1tb NVME, Samsung 960 EVO 500gb NVME, WD Black 1tb, Crucial 525gb MX300 SSD, Sandisk Ultra 500gb SSD... Lian Li Galahad AIO 240mm, Seasonic X850 PSU.
0 Likes
Chacbolay
Journeyman III

Re: Radeon W5500 New PC no display

A little background, I bought the AMD Radeon Pro W5500, I installed it in my computer with these components:
AMD FX 6300
8gb of ram at 1600Mhz
Balamrush 650W 80 Plus Bronze
Biostar A960D+
500gb sata III
I had problems for a few hours but it worked, everything was perfect for a little more than 15 days until it stopped sending image to the monitor.
I changed the monitor, the DP cable and installed a new windows and Linux but nothing worked.
I tried another GPU on PCIe and it worked without problems.
A friend lent me his PC with these components:
Ryzen 3 2200g
Asrock b350 pro 4
16 GB ram xpectrix Adata
SSD 120 GB kinston sv 400
evga 500 watts 80 plus bronze
We have used different monitors and cables but it still doesn't work on the computer.
I sent mail to AMD, they changed the card and in theory should have worked the one I have but still like the previous one, only works the fan of the W5500 but does not give image.

Sorry for my english.