cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

skyesofrock
Adept II

Radeon VII forced reboot after black screen, during games

I'm seeing the posts about the black screen bug that appears to be plaguing the Radeon VII drivers, but has anyone experienced a sudden reboot when this happens? I'm trying to work out what might be causing it, given my system *should* be operating correctly.

What happens is, during some games, my screen will freeze for a second, display is suddenly lost, audio continues for another couple seconds then stops, then the system simply reboots itself. I'm not certain this is a driver issue, but would like to hear from anyone who's had this too. If you have, it'd be great to know what the specs of your machine are too; the comparison might help diagnose the issue.

Most recent game that had this issue was Battlefront 2 2017 after maybe 80 minutes of gameplay; unlocked framerate, ultra settings so it would have been running at full capacity. This has happened across several driver versions, but is still happening on the latest 20.1.1 driver. Not sure when it started.

My rig:
- Ryzen 7 3700X
- Sapphire Radeon VII @ stock clock/voltage* (1075mV)
- 16GB HyperX Fury DDR4 @ 3200MHz
- ASUS B450-Plus TUF Gaming
- EVGA G3 750

* I have tried undervolting to 960mV which was stable for a while, then the black screen started happening and I assumed it wasn't getting enough power, so incrementally increased the voltage again

52 Replies
ajlueke
Grandmaster

Re: Radeon VII forced reboot after black screen, during games

Try the 19.4.3 driver.  That had the best stability for me with the Radeon VII.

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-19-4-3

skyesofrock
Adept II

Re: Radeon VII forced reboot after black screen, during games

Thanks for the response. I'll keep this in mind in case the 19.7.5 driver crashes; I've just installed that now and giving it a go as I heard it was good for some people.

sputnikvii
Adept I

Re: Radeon VII forced reboot after black screen, during games

My Radeon VII is stable with the 19.11.3 - every version with 20up is unstable and reboots when i need the power (Gaming or COMPUTE) . 

R7-3700X&AGESA1.0.0.4B+32GB RAM+750W beQuiet DarkPro PSU+VII with standard frequencies/voltages or UV@990mV...

I sended error reports to AMD Support because of the reproducible application errors of Radeonsoftware.exe and reboots(black screen).

AND: with the 20up versions there is no Compute 2 section in the Taskmanager at the GPU section anymore.
Just Compute 0,1,3. This "could maybe" be one of the reasons the VII/the whole system crashes and reboots when there is full load on Compute units. Users with 5700XT and Vega 56/64 don´t have Compute 2 too.

With the "old" 19.11.3 the Compute 2 section is active again and i can game and compute with full power without reboots and errors. (BUT i can´t use AMD LINK because of the "new" App-Design/requirements ).
pastedImage_1.png

calamari
Adept I

Re: Radeon VII forced reboot after black screen, during games

I've had numerous problems just like the one you describe through 2 distinct systems, 2 different Radeon VII cards (RMA-ed one) and many versions of the drivers... 

I've had my 3 screens blank to black or freeze (audio keeps going) then reset the displays and continue like nothing happened or alternatively crash / reset the system.

I've also have had so many BSD's that I can't count them - from 1 every hour to 2 a day dependent on which driver I'm running...

Decided to NOT install Adrenaline software and just let Windows install the default drivers (26.20.12028.2 dated Aug. 16 2019 - as reported by windows) and that's calmed the crashing to only about twice a day now...

I've reinstalled my OS from scratch ran tons of memory testing utils but still can't get a stable system - Loved the idea of this card and it's 16GB RAM for editing in Resolve but looks like AMD just produced a lemon here... Sigh...

Running:

Asus Z9PE-D8 WS MB

Dual Xeon E5-2670 v2 processors

64GB RAM

Windows 10 Pro

Just installed 19.4.3 as suggested above and shortly after all screens went blank had to soft - reset and windows re-installed older version - had to reinstall 19.4.3

ajlueke
Grandmaster

Re: Radeon VII forced reboot after black screen, during games

Similar experience.  With drivers post 19.5.1, my overclock settings would become unstable.  Any overclock on the Radeon VII would result in game crashes, with a "graphics device lost" error message.

I installed the upgraded software package included in driver 19.12.2 along with a clean install of Windows.  This would lead to system hangs when web browsing or just idling on the desktop necessitating a hard reboot.

I eventually rolled back to 19.4.1 using the DDU to remove the "updated" drivers.  Everything works normally.  Not a single system hang or crash.  No driver error messages when running a 200 MHz overclock either.  Everything just works.

0 Kudos
skyesofrock
Adept II

Re: Radeon VII forced reboot after black screen, during games

Did you try the 19.4.1 driver? I don't know how different 19.4.3 will be, but I heard 19.4.1 was good and I've had crashes on that too.

0 Kudos
skyesofrock
Adept II

Re: Radeon VII forced reboot after black screen, during games

Huh, I didn't even know these stats existed. On the latest 20.2.1 driver now and similarly Compute 2 is missing. I'll try 19.11.3 again and see if unit 2 is accessible again.

skyesofrock
Adept II

Re: Radeon VII forced reboot after black screen, during games

The amount of variance in card performance with the Radeon VII is astounding. The 19.4.1 driver worked for me for about 1-2 days before crashing again. Honestly not sure about going ahead with a full Windows reinstall as it just simply shouldn't require that, I don't understand.

0 Kudos
xlox
Miniboss

Re: Radeon VII forced reboot after black screen, during games

Hi maybe you can try the program called "whocrashed" to analyse dump that don't gives you a blue screen because of a graphic problem

when I have this type of blackscreen (but for me never had it in game , mostly it happens when I first start my computer in the morning , computer takes longer to start and then crash in the 5-10 minutes , then when it restarts everything is normal then and it doesn't crash for days)

it's allways because of the "video_tdr_failure" problem ,

as i was reading this thread , i remembered that before 2020 adrenalin my pc was booting normally, so I just reinstalled 19.11.3 (and compute 2 is back again too   ), now I will test and shutdown for 1 hour or 2 and see if next boot is problematic or not ...

maybe this "compute 2" thing is a good clue for amd to search for!