cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

silezn
Journeyman III

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Same here on my Vega 56 Pulse, only appears while browsing or being on desktop sometimes.

All drivers are up²date.

Hardware

  • CPU: 6600k
  • Motherboard: ASRock z170 pro 4
  • Graphics Card: Sapphire Vega 56 Pulse
  • Ram: DDR4 16GB 2600Mhz cl13
  • PSU: Corsair CX600
  • Primary monitor: Acer Predator XB240H (via DP)
  • Secondary monitor: Acer S242HLDBID (via HDMI)
  • Storage: 2x 250GB SSD's (Samsung and Sandisk)

Software

  • windows 10 Pro 64bit (version 1809)
  • AMD driver: 19.3.2
  • Vega Bios: 016.001.001.000.000000 (nothing changed)
  • Motherboard Bios: 7.50 (it's the newest)

marwyn
Journeyman III

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I just got new Radeon VII and have the same issue.

CPU: AMD Ryzen TR 2950X

Motherboard: Asrock X399 Taichi

Graphics: Saphire Radeon VII

Ram: DDR4 4x16GB 2400MHz cl15

PSU: Seasonic Prime Titanium 1000W

Drives: Samsung SSD 970 Pro (NVMe), 2x Samsung MZVPV256 (NVMe), 5x Samsung SATA SSD drive

Primary monitor: LG 43UD79-B (via 38Gbit DP cable)

Secondary monitor: I tried several types via DP or HDMI and it does not matter, the flickering on primary monitor is always present when secondary monitor is connected

Windows 10 Enterprise LTSC (version 1809, OS build 17763.195)

AMD driver: 19.3.2

Vega BIOS Version 016.004.000.038 Date 2019/02/11 14:18

Motherboard Bios: 3.30

shadowrulerx
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I am having the same issue, when im on my desktop i have these occasional strange flicker of black lines in the upper half of my screen. Ive tested my gpu in heaven and superposition and its stable but im worried it might have some faulty part. I also have two monitors. My specs are:

Ryzen 7 1700x 

16gb ram 2933mhz

Radeon VII

im using a 1080p 144hz monitor with freesync for my main

and a samsung tv for my second one

im using an asus prime x370-pro mobo

lionheart0179
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

And the issue persists on 19.3.2. I'm throwing in the towel on Andrenalin 2019 for now and going back to 18.12.1. I'll give it another go if I see that this issue has been fixed.

ryannathans
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I have exactly the same problem! Seems to occur a lot more when I open my RSS reader (FeedBro firefox addon) which has a black themed background and on websites with lots of black/dark colours - or maybe it's just more noticeable when the page is dark? Either way, gaming is absolutely fine.

i7 3770k
16GB RAM 1600MHz

Asus Formula V Maximus Motherboard

Radeon VII (19.1.1 -> 19.3.2)

Primary display Asus XG32VQ (DP)
Secondary Display BenQ G2420HD (HDMI)

I have been troubleshooting this with Kumar (AMD support) via email with no success. (ticketno:[8200866341])

ryannathans
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

ray_m: More debugging info if required, including DxDiag logs in email support ticketno:[8200866341]

Good luck

ryannathans
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

If you have this issue can you please test the following: set the high framerate monitor to 60Hz instead of 144Hz and see if the issue still occurs?

Seems to work for me (or maybe just a coincidence), but very annoying to keep changing monitor refresh rate.

60Hz.png

0 Likes
conker2009
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Hey all,

I wanted to give you all an update. I've been in contact with someone at AMD and have submitted a video with what was going on with my 7. I discovered it happened if you have a resolution that either isn't the exact same as your other monitor or the refresh rate isn't a multiple of 60. I was able to eliminate the flicker by using the virtual res to 2k for my 1080p monitor and setting my main to 120hz and it eliminated it. See if this works for you. They are looking into this and has been escalated to their engineering team.

Hope this helps some of you!

lionheart0179
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Unfortunately, that's not always the case. Both of my screens are 1080p, main is 240Hz, secondary is 60Hz. I went back to 18.12.1.1, problem is gone. I don't know what exactly they did with Adrenalin 2019, but every version has had some annoying issue that forced me to roll back, this artifacting being the worst.

colebob222
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

This works as a temporary fix for me. Thanks! I had tried setting my primary monitor's refresh rate to 120 before, but still had the issues. I hadn't tried using VSR to match resolutions though. It's good to know the engineering team is working on a fix.

0 Likes