cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I'm lucky I've never had any black screens or driver issue like you have, I would have sold the card a long time ago if I did. Just the flicker when a second display is hooked up.

This new driver for Win 10 ver 2004 did nothing to fix my problems though.

I will be upgrading to whatever top og the line RDN2 based card comes out at the end of the year so my issue is not a major one, just more of annoying.

0 Kudos
Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

So far 20.5.1 has been the best Radeon VII driver for me. 

Upon initially trying 20.4.2 on release day and seeing flickering, I angerly switched back to Vega56 (which has flickering but substantially less) and just assumed blackscreens were still a thing on VII (never had blackscreens on 56). To try and remedy 56’s flickering, I decided to give the TDR fix a go (https://community.amd.com/thread/180166). As I kind of expected, it didn’t help, as it mostly remedys blackscreens (gambit2k and frenziedmuffin I would give this a go along with setting both monitors to the same or multiples refresh rate ex: 120hz and 60hz).

A week or two ago, I decided to switch back to VII on 20.4.2 and haven’t had a blackscreen since. So, either 20.4.2 or the TDR registry fix helped with that.

As of driver 20.5.1 my flickering is thus far absent, or at least so fleeting that by the time I move my eyes to what could have been a flicker, it’s gone. However, it has only been a day and a half, thus, while hopeful, I don’t want to claim its completely gone.

This is all while having my VII substantially undervolted, to between the default minimum of 737mv and my maximum of 943mv. In fairness I haven’t actually tested at stock so it’s entirely possible this is actually helping, though I find that unlikely as many have reported raising the minimum to help with flickering (it never helped me).

For reference, the relevant specs:
Driver: 20.5.1
Windows version: 1909 (plan on updating to 2004 soon and will update if that changes anything)
GPU: Radeon VII

Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I have just reinstalled Windows, now on 2004 release, and installed the 20.5.1 drivers. Flickering now happens even with my IPTV player running. The default drivers installed by Windows have no flickering issues, of course.

0 Kudos
Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Turns out flickering is indeed still a thing, however it is very rare for me. After nearly a week I discovered it was still possible to cause flickering. The only way I was able to cause it was to scroll to a specific position on a specific webpage. Scrolling up one scrollwheel notch or down one notch completely stops it. As far as I can tell, this was not just a webpage bug as it was causing the taskbar and other monitor to flicker as well.

Aside from that one instance it is still absent for me. Hopefully this isn't the return of the flickering for me, but if its limited to that one random website I visited, then this driver is very workable for me.

0 Kudos
Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Flickering is still very much a thing.

I found a second site I was able to record it on. The weirdest thing is, this only happens if I select the "75" icon. You can see me clicking other icons and the flickering instantly stops. Luckily, this is only the second instance I have had of flickering on 20.5.1, admittedly it is far worse than before when it happens, but seems to be easily avoided.

New flickering - YouTube 

Oh yeah, sorry about the music. I uploaded straight from my phone so I added the music as there was a horrible hiss in the background.

Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Tried the new drivers, glitches like clockwork.

Installed 19.5.2 this morning and I can confirm that this particular version of the drivers fixes the issue, as previously mentioned… at least so far.

I wonder what prevents AMD from reimplementing the fix for well over a year…

0 Kudos
Highlighted
Adept II
Adept II

Re: Radeon VII flickering and artifacts when attaching a second monitor.

i'm back!

clearly no progress. this is disappointing. i'm on 20.8.2 same thing.. still flickers and artifacts. 

I've given up at this point. There wont be a fix. the card was doomed from the start. AMD has all but forgotten about it. 

AMD support just stopped responding to my issues so that was a dead end.

just saving up for a 3080 ti now.. i think i'm finally done with AMD gpus after 30 years.

Highlighted
Journeyman III
Journeyman III

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I've had this issue since i got the card and plugged in my second monitor. I have sent it in for an RMA. Getting ready to contact amazon for a return (hopefully i can work something out)... It is super frustrating that they still haven't fixed it

0 Kudos
Highlighted

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Hi Guys,

I know I solved my issue with my XFX VII but If I can help other I don't

mind.

Just to reiterate my solution based on XFX support and may for you:

I purchased 2 Active display port adapters for my TV/Monitor and HTC Vive

2nd Gen.

I plug one monitor into the direct HDMI port, my second monitor into the

display port, and my VR into the 3rd slot/second display port

This stopped the flickering and allow maximum resolution. See Picture below:

On Mon, Aug 31, 2020 at 6:55 AM thestealthtarget <amd-external@jiveon.com>

0 Kudos
Highlighted
Adept I
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Just want to chime in and say I am experiencing these issues as well as documented in this post: https://community.amd.com/thread/256956 .

0 Kudos