cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

colebob222
Adept I
Adept I

Radeon VII flickering and artifacts when attaching a second monitor.

  • Issue Description: With only my primary monitor running, no issues occur. With a second monitor running, I get intermittent issues that seem like flickering, artifacting, and tearing on only my primary monitor. These issues do no occur in 3D applications like games, but only in low-demand 2D applications such as chrome when nothing demanding is running, and the GPU is running at or around 25 MHz. Normal I'd associate issues like this with stability, but I have not done any overclocking, and it does not occur in games or when the GPU is under stress. I'm hoping this is something that can be fixed in a future driver, but I'd like to know if this is a hardware issue so I can get an RMA going as soon as possible.
  • Hardware:
    • Graphics card: Radeon VII (purchased directly from AMD)
    • CPU: Ryzen R7 1700
    • Motherboard: ASUS ROG Crosshair VII Hero (WI-FI) X470
    • RAM: 16GB Gskill FlareX 3200 MHz CL14
    • PSU: EVGA Supernova 850W G2
    • Monitor 1: Acer XG270HU 1440p 144 Hz freesync enabled
    • Monitor 2: HP 21KD 1080p 60 Hz
  • Software:
    • Windows 10 64 bit 
    • Latest graphics driver 19.2.2
    • Latest UEFI BIOS from AMD flashed
    • Latest motherboard BIOS version 1201
244 Replies
ray_m
Community Manager
Community Manager

Re: Radeon VII flickering and artifacts when attaching a second monitor.

What build of Windows 10 do  you have installed? If you haven't updated to 1809 yet, please do so since our drivers are qualified against the latest build.

Can you also try doing a clean install after updating to the latest build ?

colebob222
Adept I
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Thanks for the reply! I have been running version 1809. That's the version I've been experiencing this issue in. 

dondzila6080
Journeyman III
Journeyman III

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Hi I would like to add that I seem to be having a similar issue. I did a full reinstall of windows and ran DDU then reinstalled the drivers. The issue does not occur as often after the windows reinstall but it still happens from time to time. I have yet to see screen tearing or a bad flicker in games that are similar to what I see when just browsing. 

Hardware

  • CPU: Intel I7 - 6700k
  • Motherboard: MSI Z170A Gaming M7
  • Graphics Card: Powercolor Radeon VII purchased through microcenter
  • Ram: 16GB 2400Mhz
  • PSU: Corsair AX860
  • Primary monitor: Asus MG278uq
  • Secondary Acer GN246HL

Software

  • windows 10 64bit version 1809
  • AMD driver 19.2.2
  • UEFI bios flashed

Update: 03/02/2019

   My issue seems to have gone away with the 19.2.3 drivers. After 2 full days of being on my PC I have not noticed the constant screen tearing / flickering that I was previously. Also I did not see this fix in the update notes. 

kirurus
Adept I
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I have also been experiencing this issue. It is not very noticeable and happens very intermittently as has been mentioned. Have not yet noticed the issue in 3D applications. 

Hardware

  • CPU: AMD Ryzen 1700X
  • Motherboard: ASRock X370 Gaming-X
  • Graphics Card: XFX Radeon VII
  • Ram: 16GB 2800Mhz
  • PSU: EVGA 850 G+
  • Primary monitor: Acer KG271U Abmiipx
  • Secondary AOC 2269W

Software

  • windows 10 64bit version 1809
  • AMD driver 19.2.2
  • UEFI BIOS v106 from AMD not flashed
  • Motherboard BIOS v5.20
ray_m
Community Manager
Community Manager

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Thank you for the detailed information you provided, it is very helpful.

We're looking into this issue.

shinkojiro
Miniboss
Miniboss

Re: Radeon VII flickering and artifacts when attaching a second monitor.

I also have intermittent screen tearing and flickering with while using 2 monitors (both different resolutions, 1440p and UW 1440p)

  • Hardware:
    • Graphics card: Radeon VII (purchased directly from AMD)
    • CPU: Threadripper 1950x
    • Motherboard: ASUS ROG Zenith Extreme X399
    • RAM: G.SKILL Ripjaws V Series 64GB (4 x 16GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Desktop Memory Model F4-3200C14Q-64GVK
    • PSU: EVGA Supernova 1600w G2
    • Monitor 1: Samsung G32HG7x Freesync Ultimate mode 144hz Display port
    • Monitor 2: Samsung CF791 Freesync Ultimate mode 100hz Display port
  • Software:
    • Windows 10 64 bit  1803 (havent been given an update option
    • Latest graphics driver 19.2.2
    • Latest UEFI BIOS from AMD flashed
    • Latest motherboard BIOS version 1601
colebob222
Adept I
Adept I

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Thanks ray_m! Just to be clear, this is not a hardware issue, and an RMA would not fix the issue? We would have to wait for a driver update once the issue is resolved?

ray_m
Community Manager
Community Manager

Re: Radeon VII flickering and artifacts when attaching a second monitor.

It doesn't look like a hardware issue.

1meter60-film
Journeyman III
Journeyman III

Re: Radeon VII flickering and artifacts when attaching a second monitor.

Hello togther,

I can confirm that I have the same issues. I'm working with Davinci Resolve Studio (in Full Screen mode)  with a two monitor setup.

The problems occurs on my big UHD monitor, which is not the main monitor under windows, but the main monitor in Davinci Resolve (you can choose in Resolve, which monitor is primary display).

The problem does not occur at the beginning. I work sometimes for round about 4 hours with no problems. And than suddenly this behavior begin. And I did not very GPU intensive stuff. I worked on Subtitles which does not challenge the GPU. 

I will test, if this flickering stuff will change to the other monitor, when I change the primary Display inside Resolve.

My System is:

Hardware

  • CPU: Intel I7 - 8700k
  • Motherboard: ASUS RIG STRIX Z370-E Gaming 
  • Graphics Card: Gigabyte Radeon VII 
  • Ram: 32GB
  • Resolve-Primary monitor: Samsung UE55KS7090 (UHD TV) over the HDMI out in UHD 50p, RGB, 8bit Full range.
  • Resolve-Secondary monitor: Standard HD Display LG 24MB56, in HD 50p, 8bit, full range.

Software

  • windows 10 64bit version 1809
  • AMD driver 19.2.2
  • GPU bios flashed with V106

With the Bios Version before v106 I encountered also one system Reboot when working with Resolve, after this flickerings occure. But I'm not shure, if this connects.

Because I had also two unexpected crashes from Resolve when I was rendering the finished film. I will check, if the new BIOS Version will help in this regard.