cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

brockenflabel
Adept I

Radeon settings and driver versions do not match

I recently purchased Acer Nitro 5 515-42-R5ED.  It comes with integrated vega 8 and RX560X video card.

I tried updating windows 10 and radeon drivers but had a couple problems.  One problem is drivers

won't properly install, second problem is memory leak during trying to play a game.

Radeon display utility doesn't show up.

I purchase game No Mans Sky(opengl), got only 3fps.  I found a no mans sky profile setting called tkgraphicsetting.

Inside it said it was using vega 8 integrated graphics?

I tried every solution on google, finally discovered a Windows 10 settting called Graphics Settings, where you can manually set which game.exe to force it to use the videocard.  After doing this it seemed to improve, getting

anywhere from 15 fps to 25fps.

Then windows 10 did a couple more updates.

kb4487044 security
kb4487038 adobe
kb4480979 adobe
kb4462930 adobe
kb4483452 .net  (problem?) frame rate went from 5 to 25fps

And frame rate dropped to 5fps.

I tried uninstalling kb in certain order and it worked.  Then they reinstalled themselves,  I uninstalled them one by

one using wushowhide.diagcab this time. but different order gave same result?

kb4487044 security (still slow after this uninstall)
kb4483452 .net (still slow after this uninstall)
kb4487038 adobe (still slow after this uninstall)
kb4462930 adobe (frame rate went from 5 to 25fps again)

All the while my graphics driver won't install properly either.

A) if i used auto detect drivers it always says "components are already installed."

 even if I have no AMD drivers at all on computer?

B)if I use the full adrenaline driver package install it says"

1603 error
no graphics driver is installed and the graphics driver is not
functioning properly. please install the graphics driver appropriate for your hardware."

I found something on google about [HKEY_LOCAL_MACHINE\SOFTWARE\AMD\CN]

and they said just delete the version number.  After doing this I finally got Radeon utiltiy

to show up, but it won't save any profile and when I click on global settings in crashes to desktop.

One thing I noticed tho was that [HKEY_LOCAL_MACHINE\SOFTWARE\AMD\CN]

value is 25.20.15017.1010

but in control set drivers are 23.20.826.12544

they don't match?

What did I do to resolve all this over last week now?

-used Windows update utility to get latest updates

-sfc scannow

-dism

-repair visual C++ libraries

-clean uninstall using AMD clean uninstaller.

-clean uninstall using DDU uninstaller.

-So what is going on?  why would the AMD drivers allow two different driver versions?

when I can get radeon driver utility to show up it says 17.7 display version

but when I go into windows apps, under AMD it says 19.2?

So I'm kinda confused now as to what the problem is

1)windows 10 memory conflict

2)radeon memory conflict

3)opengl memory conflict

***Recently I tried to get the No Mans Sky game profile in radeon to use

triple buffering and save it.  No when I play no mans sky its back down

to 5fps?  so its some kind of memory conflict somewhere?

0 Kudos
6 Replies
brockenflabel
Adept I

Re: Radeon settings and driver versions do not match

Well I retried a few more experiments.


1) -I used AMD Cleanup utility
-then used Windows 10 updater to update video drivers.
-Result:if I can remember, i think it installed a 13 month old rx560x driver but
left the integrated driver Vega 8 totally untouched?
-also No Mans Sky frame rate 5fps
-also I think the driver version was 17.7? 13 months old?

2) -I used Amd cleanup utility
-I then used AMD auto detect video drivers.
-Result: message came up saying something like "best video drivers are currently installed already"
-How in heck can Microsoft Basic Display driver best Best driver according to Amd auto detect installer?
seriously?

3) -I used amd cleanup utility
-I then ran 19.2 full installation adrenaline drivers for radeon rx560x drivers package.
-Result: no mans sky 5fps.

3b) -I then looked up full installation driver package for Ryzen 5 and vega 8.
which was like 19.1 driver.
-I then ran Windows 10 updater.
-Result: 25fps !
-But I can't get Radeon display utility to show up
when I click on the radeon in taskbar to open, it gives
error message
no graphics driver is installed and the graphics driver is not
functioning properly. please install the graphics driver appropriate for your hardware

So I think so far it may be three problems,
1) if bad radeon drivers
2) bad opengl drivers.
3) fire the guy who made them.

0 Kudos
goodplay
MVP

Re: Radeon settings and driver versions do not match

There are currently no AMD drivers available directly for your product.

At the moment only the drivers supplied by Acer are recommended.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb, Nitro+RX6900XT,
0 Kudos
brockenflabel
Adept I

Re: Radeon settings and driver versions do not match

I'll get around to unistalling the Radeon drivers and install the older Acer drivers?  and see if there is still 

an error message.

p.s. I tried a few direct x games during the memory leak phase and they ran ok.  I want to find

another opengl game and see if it has the same memory leak problem.

0 Kudos
brockenflabel
Adept I

Re: Radeon settings and driver versions do not match

Thanks Goodplay.

I did exactly that.

Even though the Acer drivers are older, not by much.  I got the display console to work now without any errors.

0 Kudos
estiakahmed008
Adept I

Re: Radeon settings and driver versions do not match

0 Kudos
who_am_l
Journeyman III

Re: Radeon settings and driver versions do not match

I found a solution for the AMD Radeon Software & Drivers Bug "Radeon Software and Drivers versions do not match. Please try again after updating to the latest version(s)." and  "Radeon Settings and Driver versions do not match. Please try again after updating to the latest version(s)." To solve the bug, please follow the steps:

  1. Open the Device Manager
  2. Search your graphic card (Display Adapters > Your Graphic Card)
  3. Right click it and open the Properties
  4. Go to Driver and click Update Driver
  5. Browse now your computer for drivers
  6. Pick the list of avaible drivers on your computer
  7. Select the latest installed AMD Radeon Driver and click on next

Now, the AMD will be install and after that, restart your pc and the AMD Driver will work.

0 Kudos