cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Arkerian
Journeyman III

Radeon RX 580 Series crashes game and no longer appears in Device Manager

Card: Radeon RX 580 Series
Computer: Desktop
OS: Win 10 Home 65 bit (10.0, build 19044)
Driver: currently 22.2.3 (have also tried 22.2.4 I believe as the card has seemingly lost the drivers somehow and I had to redownload them at times)
Displays: 2 displays - Dell SP2309W (HDMI, 60 Hz, connected to rx 580) and Dell SP2309W (Analogue, 59.909 Hz, connected to Intel(R) HD Graphics 630), both 2048x1152
CPU: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz 3.60 GHz
Motherboard: ASUSTek, PRIME B250M-A
Power Supply: Can't access this easily, but should be default for this prebuilt, I believe it was 600W, can try to open it up if needed.
System Memory: 32 gig (2x16gig?) Corsair Vengeance DDR4 (this is all the info I've been able to find)

Description:
Various things have happened at various times. I'll do my best to explain.
I have played Warhammer: Total War 3 (vers. 1.0.1, graphics: medium, res: 1920x1080, windowed) and other games. During battles the RX 580 seems to stop working as the monitor plugged into it goes dark and sometimes the card no longer appears in the Device Manager. The game ceases functioning and the CPU becomes very loud suddenly (I assume the cpu and motherboard GPU are suddenly trying to handle the game or something). I noticed when opening the Control Panel the CPU is running at 100% now despite nothing showing up as taking more than 0% of its resources. So I end up restarting the computer.
Sometimes the Device Manager does not recognize the RX 580 so I can only fix it through Shutting Down the system and removing and reinserting the card. This seems to cause me to need new drivers as well. But it allows the card to be seen again.

Sidenote: Sometimes recently I've gotten an error when opening some games saying something isn't supporting OpenGL. I just tried this with RX 580 currently working and I did not get errors opening these games. Maybe this is simply telling me motherboard GPU cannot handle OpenGL?

0 Likes
2 Replies
since25
Adept I

Hey,
I experience the same problem, but with RX 570 4Gb. Did you find any solution for that problem? 

0 Likes
since25
Adept I

I described my problem in more detail in that text:

https://community.amd.com/t5/graphics/radeon-rx-570-signal-loss-hard-reset-and-reboot-without-gpu/m-...

Do you find your problem the same? 

0 Likes