cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

therobster5555
Adept I

Radeon RX 580 POST issues

Hi AMD community.

I have an ASUS ROG Strix RX 580 8GB that I got used and was advertised as artifacting and sometimes doesn't work at all.

When I got it home, after like 4 reboots I got it to POST and I gamed on it for a good hour and no artifacting at all.

Afterwards, I was no longer able to get the card to POST into the BIOS, however if I turned on my CPU integrated graphics, (this is a 4th gen intel board) the BIOS still wouldn't appear on the Radeon, but once Windows loaded up, it works fine.

I've already tried flashing a vBIOS from TechPowerUp to no avail, (though I didn't kill the card so that's a win in my book) but I'm still fairly certain that it is a vBIOS issue. I also tried putting this GPU into a Core 2 Duo rig and that posted into the BIOS, but in a text only mode and when I tried to go into the BIOS setup, it came up with an error that said, "Error: Can't enter Setup. Video Mode 103 is not supported by this video card."

Any help is appreciated!

0 Likes