cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

LopiGames
Journeyman III

R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

I just bought a Sapphire R9 280x Dual-X OC, and when I put it on my PC, its is shown like "R9 200 Series" everywhere, and I also can't see the power consumption, even in Radeon Software or in MSI Afterbuner. 
I have the latest driver version, so I don't know what's wrong.
My pc specs:
CPU: Ryzen 3 1200
GPU: Sapphire R9 280x Dual-X OC 3gb GDDR5
RAM: 16 Gb 3000mhz
M.B: Gigabyte AB350M-DS3H V2
SSD: 240gb
HDD: 320gb 

0 Kudos
8 Replies
elstaci
MVP

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

Can you post an Image of GPU-Z for your GPU card?

Now compare GPU-Z Data with those from TechPowerUp concerning your SapphireDual-X R9-280X GPU Card: https://www.techpowerup.com/gpu-specs/sapphire-dual-x-r9-280x-oc.b2463

The data should be identical. Also check the BIOS Version and then click on the upper Right corner "Look Up" to see if shows the correct GPU card.

Could just be the AMD driver not posting the exact Model.

kingfish
MVP

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

Run GPU-Z and select lookup...it will tell you exactly what card in the 200 series you have.

Screenshot_2.png

LopiGames
Journeyman III

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

Here are some screenshoots, they are exactly the same, and I tested it on some games and they run as expected.
sddsd.gif

LopiGames_0-1614990303008.png

 

0 Kudos
LopiGames
Journeyman III

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

This is what I get when clicking on lookup xd

LopiGames_0-1614990612229.png

 

0 Kudos
goodplay
MVP

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

A number of different model sapphire cards used the same vbios vers. #, if you bought it used the previous owner may have flashed it to different model spec.

Could be a reason TPU is showing 2 cards ?

You could contact Sapphire tech. support to find out which exact model you have (provided all the I.D. stickers are still on the card).

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb, Nitro+RX6900XT,
0 Kudos
kingfish
MVP

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

What is the problem? You have a Sapphire R9 280OC card....just like you are supposed to have.

0 Kudos
LopiGames
Journeyman III

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

Ok, thanks! I will try that. It can be a reason, yes.

0 Kudos
LopiGames
Journeyman III

Re: R9 280x shown as "R9 200 series" in gpu z, radeon software, and msi afterburner.

Not really a big problem, but I wanted to see the gpu power consumption and I can't, just that.

0 Kudos