cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

loccothan
Adept III

Problem with Monitor EDID/Freesync

I've installed (Upd.) new WinX 1903 and Adrenalin 19.5.1 & 19.5.2

Everything was good until i Turned ON Variable Refresh Rate in Display settings/GFX settings

My screen turns RED (yup only one colour, shades of Red)

IMhO it's EDID related bug in Windows or Drivers

Im using CRU (Monitor Tests Forum - Monitors & Video Cards )

Here is my monitor specs ( https://iiyama.com/pdf/Product/512/gb_en.pdf )

When im not using CRU, my monitor is 70Hz 10Bit panel but with FreeSync range of 48-70 instead of 35-70 !

Also the bug returns if i switch ON VRR in Win Display settings.

That's an hudge difference. Thanks to CRU im able to get FS range at Great 30-70Hz.

No Tearing/lag or anything in this combo, Forza DX12, VLK Games & DX9/10/11.1 Performs Great.

Please check this behaviour.

I'm not seeing Red Bug anymore (Steps to make):

1. Reset CRU

2. Set only basic settings in CRU (do not put monitor H/V leave it at default) + FS range 30-70

3. Restart & don't touch the Windows Variable Refresh Rate (Set to OFF before restart)

4. Gaming NP no Red bug.

My System:

ZEN 8/16 1700 with 32GB 4x8 at 3466CL14 LLC | Hero VI BIOS 6401

Vega 64 Original XTX LC by AMD (UV and max clocks for gaming 1668MHz 1.094v | HBM2 at 1120MHz 912mV)

SB-Zx + 1TB SSD

===

Screens:

Variable bug.jpg

===

Variable Red bug.jpg

====

Problem is semi-solved !
Games no longer gets Red bug.

But after loading of windows (first time) after 30sec. screen gets red or pink (or sometimes green)

It can be restored if i enter into windows Display settings (right click on desktop then Display settings).

Then is fine VRR can be turned ON and can Play games NP.

So Valid ranges are not the case, the problem is driver or OS.

No such problems at Win 1809.

When VRR is OFF everything is fine.

If You have it ON then after restart You need to go into Display settings once.

I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !

IiYama ProLite XUB2792QSU
DP w/o FreeSync = H=30,0-89,0 V=50-75
DP w/FreeSync = H=30,0-115,0 V=48-70

Last pages here:
-> https://cdn.iiyama.com/f/dd7b66fcdb91e2756c1410e9faa9ee52_xub-xu2792qsu-usermanual-e-revb.pdf

So to solve this, i needed to dig deeper into Monitor Specs, and input Valid ranges + go into Display settings once after restart/boot.

Im 90% sure that this is new Win 1903 bug... & not AMD/ATI Fault.

But guys if You can look into this problem.

I was gaming few days and everyhing was OK, then i saw this VRR in Win settings and i go for it -> Bug happend !

Variable no bug.jpg

===

Problem solved !
Games no longer gets Red bug.
I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !
Problem solved !
Games no longer gets Red bug.
I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !
Problem solved !
Games no longer gets Red bug.
I've Read through IiYama User Manual and there is 2 different settings (H/V) for DP
With FreeSync & without !
Last pages here:
IiYama ProLite XUB2792QSU
DP w/o FreeSync = H=30,0-89,0 V=50-75
DP w/FreeSync = H=30,0-115,0 V=48-70
Now it's working fine.
0 Likes
5 Replies
unclehamish
Adept I

Re: Problem with Monitor EDID/Freesync

Hi loccothan

I have roughly the same problem. I have a Samsung LC27HG70 and after installing 1903, Freesync Ultimate Engine (48Hz-144Hz with LFC) on my monitor would not work, giving me a blank screen, only standard Freesync 120Hz-144Hz or Freesync off would work. My monitor has 3 buttons to store separate profiles and when I switched from the Freesync Ultimate to normal Freesync (to get rid of the blank screen) my desktop would go red, only pressing normal mode would clear it.  The problem that scared me most was that the monitors on- screen menu would get corrupted, resulting in me thinking the monitor was on its way out. This seems to confirm the same as you that the problem is a windows or driver bug in the EDID information. Bear in mind all this occurred without switching on the new Variable Refresh Rate option in Windows 10 1903, the fact that it is now included as an option is enough to cause a problem.

I rolled back to 1809 and the problem completely disappeared. I hope AMD/Microsoft have a look at this as I'm sure we are not the only ones that suffer from this, giving that we are using different monitors.

Adrenaline drivers used with 1903: 19.5.1, 19.5.2 and 19.4.1 all same result.

System specs.

Zen 2700X@stock

XFX RX480 8GB GTR Black Edition@stock

Asus X470-F Gaming-BIOS 4207 (most stable)

Corsair 2 x 8GB 3000Mhz@stock

goodplay
MVP

Re: Problem with Monitor EDID/Freesync

Some articles on the web,

Haven't found any MS Dev articles as yet.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes
loccothan
Adept III

Re: Problem with Monitor EDID/Freesync

ThX for the response.

Interesting to see that even without turning this Feature On gives anomalies.

I found the way to get stable (no bug) settings, so far it's fine.

It's 100% Edid problem, and Yes if You turn OFF Freesync -> the bug is totally gone.

0 Likes
loccothan
Adept III

Re: Problem with Monitor EDID/Freesync

It seems they fixed something in last WinX update.

The Bug is gone.

Driver was updated (yesterday) to WHQL 19.5.2 (Release Date 6/3/2019)

No problems so far, stable & fast.

GPU/HBM2 clocks behave as they should.

0 Likes
loccothan
Adept III

Re: Problem with Monitor EDID/Freesync

Problem is no more

Today i've installed new WHQL -> 19.6.2-june24

And everything went smooth, no redish/pink or such screens.

To be noted, that i have Loaded ICC profile for my monitor into Windows.

Im also using CRU, all Fine.

THX ATI/AMD

0 Likes