cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

ghostventuri
Adept I

Problem while using integrated graphics card - Athlon 3000G

Hello! I've bought an Athlon 3000G a few months ago and I would like to test the integrated graphics card, considering that it's probably better than my current offboard GPU (Nvidia GT 740). Unfortunately, after downloading and installing the drivers, the PC just stays infinitely on the loading screen.

The PC works well while using the offboard GPU.

I would like to know what's going on and how I can solve the problem.

Best regards,

Venturi

 

PS: I'm a newbie, so... If the problem is easy to solve for you, please, be kind and don't mock me.

0 Likes
8 Replies
elstaci
MVP

First remove the Nvidea GPU card from your PC and use DDU with the Internet disconnected to eliminate all traces of the Nvidia Graphics driver.

Once DDU reboot into Windows Desktop do the same with the AMD driver in case it got corrupted during the installation. Delete the AMD Installation folder at CAMD also for Nvidia, if created, at C:\Nvidia.

Download the full AMD package from AMD download page and run it. If it installs successfully, re-connect the Internet and again delete C:\AMD folder: https://www.amd.com/en/support/apu/amd-athlon-processors/amd-athlon-desktop-processors-radeon-graphi...

0 Likes

Hi! Thanks a lot for your reply. Sorry for the late message.

I've followed all the procedures with the PC offline and unfortunately, the result was the same again. When I restart the PC to finish the AMD setup it just loads infinitely.

0 Likes

Sounds like a driver is having problems loading when Windows starts.

Can you please post your computer information: Make & Model of your Motherboard, GPU, CPU/APU, Windows and BIOS  version installed?

When you remove the AMD Driver does it boot up into Windows?

 

0 Likes

Motherboard: ASUS PRIME B450M-GAMING/BR

BIOS: Brand: American Megatrends Inc. Version 3002, Date: 03 Nov, 2021.

CPU: AMD Athlon 3000G with Radeon Vega Graphics

APU: Radeon Vega 3 Graphics. Graphics Core: 3. Graphics Frequency: 1100 MHz

Does it boot up after removing the AMD Driver? Yes.

0 Likes

Try updating to the latest NON-BETA BIOS version 3604 and see if that helps from here: https://www.asus.com/us/SupportOnly/PRIME%20B450M-GAMING-BR/HelpDesk_BIOS/

Also try installing Asus Graphics  Driver and see if that makes any difference: https://www.asus.com/us/SupportOnly/PRIME%20B450M-GAMING-BR/HelpDesk_Download/

Here is AMD latest AMD CHIPSET Package for the B450 Motherboards: https://www.amd.com/en/support/chipsets/amd-socket-am4/b450

EDIT: Here is the Brazilian Asus Support page for your motherboard:https://www.asus.com/br/Motherboards-Components/Motherboards/PRIME/PRIME-B450M-GAMING-BR/HelpDesk_Do...

Same information as the English version from the first Asus link I posted.

Thanks a lot for your answer. Considering the complexity of some procedures (Mostly the update of BIOS), I'll leave this task for a professional to minimize the risks. But I really appreciate your effort trying to solve my problem.

Cheers,

 

UPDATE:

On last friday, I've tried the two options that I still had available.

- 1) A clean Windows 10 reinstall;

- 2) BIOS UPDATE.

1) The clean Windows 10 reinstall did not make a single difference on the result. Same error while on the Windows logo screen, not completing the start.

2) The BIOS update did not work really well. The computer started to freeze and I needed to return to previous version to make it work well again. I've used the version 3604, from March 16, 2022 for my test. I had to return to version 3002, from March 2021.

It took me some hours to test both procedures, so I quitted my experiments for now.

 

So... Do you have a better idea of how I can make the APU work on my PC? It would be very appreciated.

0 Likes