cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

eliofernandes
Adept I

PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

just bought this card to replace my gtx 1070, my psu is 600 w. card will turn led lights on but no display image or booting. any ideas? thanks in advance

0 Likes
1 Solution

Accepted Solutions
one123
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

I have the same videocard red devil 6600xt and i had same problem.I changed slot pcie on motherboard,no boot,other card rx570 boot without problem.

Changed psu seasonic snow silent,no boot,bios reset,enable/disable sam(with other videocard0,no boot with 6600xt.

After 2 day struggle,when i was ready to return videocard,i read on internet from someone to try 2 separate cable from psu,even this card consume only 160W TDP.

From monday im trouble free,benchmark,game,boot every time.

View solution in original post

16 Replies
elstaci
MVP

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

Computer information would be helpful.

Do you have the GPU card 8 Pin PCIe Power cable connected from the PSU to the GPU Card?

What Motherboard Trouble LED's are lit when you power up the computer and have no video output nor boot up?

It is possible the computer is booting up by looking at your Computer Case HDD LED light. If you turn on power and you see the HDD LED light flickering or solid then the computer is booting up but without any Video output.

When you mentioned it doesn't boot up does that mean the computer shuts down immediately or all the Motherboard lights and fans are working including the CPU fan are running but without any video output?

Since you can't enter BIOS since you have no video output try connecting your TV set or some other monitor and see if you get video output or not.

0 Likes
eliofernandes
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

computer boots up, ssd's, dvd, cpu etc even gpu led on but no display output or image and yes 8 pin connector plug as well. when i put back my old gtx 1070 everything works fine. actually im quite good with computers (worked as it technician years ago) the only reason im here to get some help its because i dont have spare parts or a pc to test this new card. 

my pc specs: i8500, 16gb ram, asrock MB 365, 1 hd 4.5 tb, 1x ssd  500 gb, 1x ssd 128 gb,1x mvm2  1 tb, psu 600w corsair, gpu rx660 xt or gtx 1070

0 Likes
elstaci
MVP

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

Ah, I understand.

When I upgraded my computer from a Non-Ryzen PC to a Ryzen PC I also didn't have any video output. My Asus Motherboard Trouble VGA LED would light up. Unfortunately my Computer case HDD LED wasn't working at the time but I did get BEEPs indicating VGA issue at booting up. So after a couple days of trying everything to get video output on my 4K LG Monitor I took my GPU Card (Asus GTX 1070) to a computer shop that checked it out by installing it on a motherboard.  Immediately at the computer shop he had video output. So then I took my entire Computer case to the same computer shop and I was amazed to see that it booted up with Video output. So I knew the issue was with my monitor.

So I went home and connected my GPU card to my Samsung TV and had video output. In BIOS I changed the BIOS setting from UEFI mode to CSM Mode. Immediately I had video output on my 4K LG Monitor.

This is not the same in your case since your Nvidia GPU card works fines while booting up.

I assume you have tried other GPU video outputs to see if you get video to your monitor during the boot process?

Try installing the 6600XT on a family or friends computer and see if you get the same results. If you do I would open a Support Ticket with PowerColor and see if they believe you need to RMA the GPU Card for testing.

EDIT: Reread you last post and you mentioned you don't have a PC to test out the new GPU card. In that case I would ask PowerColor Support and see what they recommend.

Even though you probably haven't installed AMD Graphics driver you should still get Video Output from your GPU card during the booting up process.

0 Likes
eliofernandes
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

well the only choice is to sent gpu to ebuyer uk. i already open a ticket for a refund.

0 Likes
one123
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

The videocard is ok,please try 2 separate cable from psu.

eliofernandes
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

my psu only have one cable

0 Likes
one123
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

I have the same videocard red devil 6600xt and i had same problem.I changed slot pcie on motherboard,no boot,other card rx570 boot without problem.

Changed psu seasonic snow silent,no boot,bios reset,enable/disable sam(with other videocard0,no boot with 6600xt.

After 2 day struggle,when i was ready to return videocard,i read on internet from someone to try 2 separate cable from psu,even this card consume only 160W TDP.

From monday im trouble free,benchmark,game,boot every time.

eliofernandes
Adept I

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

well i thought i had just one 8 pin cable but have two so i did that plug them two and guess what? it works lol 

THANKS EVERYBODY 234340484_254774869826513_7379361674166658652_n.jpg237216493_4137437676378451_5725803228101411409_n.jpg

elstaci
MVP

Re: PowerColor Red Dragon RX 6600 XT no display, won't boot into BIOS, LED LIGTHS ON

Jump to solution

I suggest you mention this to PowerColor Support since this is the second known case where a daisy-chained PSU to GPU Power connections doesn't work.

I have heard the same thing concerning the AMD Vega GPU cards in the past but this is the first time I hear about it for a Non-Vega GPU card.

Anyways, Kudos to @one123 for finding the solution to your issue.

0 Likes