cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Journeyman III
Journeyman III

Powercolor Red Devil Vega 56 messed up after Adrenalin Edition 18.3.4 update

My Vega 56 stopped responding to driver after the newest update. Despite using DDU uninstaller and clean install of new driver it doesn't respond. I've also tried clean install of Windows 10. The fans of the GPU seem to work when the card is disabled in Device Manager but it stops working after enabling. The fans also work when the AMD drivers are uninstalled but they stop working immediately after I install the drivers back.

0 Kudos
2 Replies
Highlighted
Exemplar
Exemplar

Re: Powercolor Red Devil Vega 56 messed up after Adrenalin Edition 18.3.4  update

sounds like a bios-error, did you mod it? did you bought the card used?

try to patch your driver with AMD/ATI Pixel Clock Patcher

if that didnt help - try to reinstall your Windows

0 Kudos
Highlighted
Big Boss
Big Boss

Re: Powercolor Red Devil Vega 56 messed up after Adrenalin Edition 18.3.4 update

The fans don't run all the time. Without the driver they are probably on. Once the driver is installed and monitoring temps it turns them off unless the temperature rises enough to run them. Current generation cards are much more geared to being quiet. They don't run the fan all the time like older cards.  So if that is the only reason you believe you have a card issue then you may not have a card issue. If you do still believe you do them explain why and provide the following information please: INFORMATION REQUIRED WHEN POSTING A QUESTION  If you want one of your peers here to try and help.

I would also remind you that Powercolor, the people that made you card should be able to answer your questions as they are the experts on your card.