cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

NovemberGaming
Adept I

PCIE 4.0 not running full speed

Jump to solution

So my RX 6500 xt supports PCIE 4.0 my motherboard also supports it. However on the Radeon software it says that my bus type is 4.0 however the current bus settings are on 3.0 x4.

0 Likes
1 Solution

Accepted Solutions
elstaci
MVP

Re: PCIE 4.0 not running full speed

Jump to solution

Your Ryzen 5 1600X doesn't support PCIe 4.0 only 3.0 version. That is why your motherboard is showing PCIe 3.0: https://www.amd.com/en/products/cpu/amd-ryzen-5-1600x

Screenshot 2022-02-27 093811.png

You will need to upgrade your processor to a 3000 or newer. This tech site has a chart showing which processors support PCIe 4.0:

Screenshot 2022-02-27 093811.png

 

View solution in original post

6 Replies
elstaci
MVP

Re: PCIE 4.0 not running full speed

Jump to solution

In BIOS you can change the PCIe lane from 3.0 to 4.0. unless your GPU card is a 3.0 type card.

Also depends on which PCIe x 16 slot you have the GPU card installed. Some processors, especially APUs only support 3.0 and not 4.0 while the latest Non-APU processors supports 4.0.

Most X570 Motherboard Chipset supports 4.0 so depends which slot you have your GPU card and Processor you have installed.

Depends on the Make & Model of your Motherboard how it designates PCIe x 16 slots as 3.0 or 4.0

Do you have any other PCIe card installed on another PCIe x 16 slot in your motherboard?

Need to post your computer specs. To many factors involved.

Can you upload an image of GPU-Z?

0 Likes
NovemberGaming
Adept I

Re: PCIE 4.0 not running full speed

Jump to solution

In the Bios it also gives me the option to enable PCIE 4.0, however i keep it on auto.Unbenannt4.PNG

Unbenannt3.PNGI

 

0 Likes
elstaci
MVP

Re: PCIE 4.0 not running full speed

Jump to solution

If it is on "Auto" that means for some reason BIOS sees your GPU card as a 3.0 GPU card unless  your processor doesn't support 4.0 PCIe  slots.

Can you post your Make & Model of your Processor please?

Here is the Specs on your MSI Motherboard concerning the PCIe slots: https://www.msi.com/Motherboard/B450M-PRO-VDH-MAX/Specification

Screenshot 2022-02-27 093811.png

Looks like your Motherboard support 4.0 via a BIOS update. But in the Specs which must be out-dated with the original BIOS that didn't support version 4.0 in the past.

Your Manual doesn't mention anything about having PCIe 4.0 slots. Only PCIe 3.0 slots:

Screenshot 2022-02-27 093811.png

You seemed to have a fairly old MSI Motherboard. Once you tell me what processor you have installed it would be helpful.

 

0 Likes
NovemberGaming
Adept I

Re: PCIE 4.0 not running full speed

Jump to solution

Unbenannt2.PNGUnbenannt1.PNG

0 Likes
elstaci
MVP

Re: PCIE 4.0 not running full speed

Jump to solution

Your Ryzen 5 1600X doesn't support PCIe 4.0 only 3.0 version. That is why your motherboard is showing PCIe 3.0: https://www.amd.com/en/products/cpu/amd-ryzen-5-1600x

Screenshot 2022-02-27 093811.png

You will need to upgrade your processor to a 3000 or newer. This tech site has a chart showing which processors support PCIe 4.0:

Screenshot 2022-02-27 093811.png

 

NovemberGaming
Adept I

Re: PCIE 4.0 not running full speed

Jump to solution

Thank you for helping me, i wont be able to upgrade for the next two years so i probably will have to deal with it.