cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Journeyman III
Journeyman III

Nothing indicate that I have AMD device on my Laptop.

Hi Guys,

I have problem with my laptop (Toshiba Satellite S70-B), I bought 2 years ago and it was working fine until 3 days ago were my Radeon R9 M265X disappeared completely while downloading a game in steam over the night before the problem happened.

I can’t see it in the Device Manager, the only thing is under Display Adapters is Intel HD Graphics 4600:

IKF5nS1

And If I tried to install the driver for AMD card it gave me this:

(Error 173AMD Installer Cannot Continue Since AMD Graphics Hardware Was Not Found)

1XV7f7J

Laptop specification:

Operating System

                Windows 10 Home 64-bit

CPU

                Intel Core i7 4720HQ @ 2.60GHz

                Haswell 22nm Technology

RAM

                16.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)

Motherboard

                FF10 06C6 (U3E1)

Graphics

                Generic PnP Monitor (1600x900@60Hz)

                Intel HD Graphics 4600 (Toshiba)

    Radeon R9 M265X

Storage

                931GB TOSHIBA MQ01ABD100 (SATA)

Things I tried to do to fix the problem so far:

  • Install the official driver from Toshiba website using DDU. (No hardware detected)
  • Install driver from AMD website using DDU. (No hardware detected)
  • System Restore to the time before the problem. (Only Intel HD 4600 under Display Adapters)
  • Clean Install Windows 10 & Windows 7. (Only Intel HD 4600 under Display Adapters)
  • Reset BIOS, Flash BIOS and Downgrade BIOS.
  • Unified Leshcat Driver for AMD & Intel drivers.
  • Removing the CMOS Battery and put back.
  • Unplug RAM & Hard Drive and plug it back.

So basically, I did everything I could find in the internet and still there is only Intel HD 4600 under Display Adapters, I am not sure if the AMD is dead, but I think if it's dead at least I will find some notification on the Device Manager to tell that there is something wrong with the device.

If there is anything I didn't clear it about the problem please ask me to do so.

I will appreciate any help guys.

Thanks.

0 Kudos
8 Replies
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

Hi abdshak,

did you solve the problem with gpu in Device Manager? I have the same gpu problem not showing in device manager on my toshiba with windows 10...if you could help me here how to fix it please.

Thanks,

Flip

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

Hi Filp,
I am really sorry for the late reply, I had a busy month.

I didn't solve the problem, the GPU disappear completely like I never had one. Most likely it is dead, at least this my case. I recommend to try what I mentioned above (Things I tried) before jumping to the same conclusion. Basically those all the suggestions to fix the same problem gathered from the Internet.
Hope you already solve the problem.
Shak

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

Hey no problem,

i didn't solved the problem, so odd because the notebook is new and i have tried all options as i could and nothing...

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

Yea, I know what you mean, It's the most frustrating thing I faced.

Btw, are you a gamer by any chance? because I remember that the night before the problem, I played Rainbow Six Siege for 6 hours on 10fps and then I woke up to find the GPU dead. Did you encounter the same situation ?

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

My case i was playing Fortnite suddenly one day i've notice the graphics was very low and when i go to the device manager the main graphic card amd just gone...

All options that i have tried sometimes the card was being detected but not for long, won' t stabilize ...sometimes when the network card shuts down the graphic card shows up from nothing...now lately won't show up not matter what...seems doesn't never exist.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

I see, I had so many problems with my laptop as well. tbh I just gave up trying to fix the GPU problem, and I am gaming on the integrated GPU (Intel)
Last week my laptop was so slow ( Disk usage always 100%) even after I did a fresh Windows install, so I had to shut down the hard drive, and use Windows to go on external. so far is running like new one. but still no dedicated GPU (AMD).

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

Have you ever tried to open the notebook? Try changing some options in the bios as well? My Bios doesn't have switchable graphics...

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Nothing indicate that I have AMD device on my Laptop.

Yes I did try to reset BIOS, flash BIOS and downgrade BIOS but nothing helped. as for switchable graphics option I dont think the original BIOS veriosn support that.

0 Kudos