cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Soln
Adept I

No OpenCL / hardware acceleration in Affinity Photo for over a year now

Why? When? **bleep**?

0 Likes
8 Replies
elstaci
MVP

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

First need to post your Computer hardware.

Make & Model of GPU card, CPU/APU, Motherboard, Windows or MacOS version, AMD driver installed, etc.

First thing I would do is run GPU-Z and see if OpenCL is enabled by the AMD Driver for your GPU card. At the bottom of GPU-Z are several APIs including OpenCL boxes.  

The OpenCL, OpenGL, and Vulkan API should be check marked and enabled. If they are not then your AMD driver isn't installed correctly or is corrupted.

Here is Affinity Help concerning OpenCL : https://affinity.help/photo/en-US.lproj/index.html?page=pages/Extras/hardwareAcceleration.html?title...

Screenshot 2022-05-20 114321.png

0 Likes
kingfish
Volunteer Moderator
Volunteer Moderator

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

What are your computer specs? Is this a laptop? Intel processor?

There are many posts (searching Google) that point to specific AMD graphics cards and Affinity Photo. Here is one that explains it better:  https://forum.affinity.serif.com/index.php?/topic/136615-known-issue-hardware-acceleration-and-amd-r...

Screenshot_1.png

Possible work around:

OpenCL™ and OpenGL® Compatibility Pack

https://apps.microsoft.com/store/detail/opencl%E2%84%A2-and-opengl%C2%AE-compatibility-pack/9NQPSL29...

 

 

elstaci
MVP

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

@kingfish 

Great find. Now we just need to wait and see which type of AMD GPU card the OP has.

Soln
Adept I

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

Sorry, I should have been more precisive. And I should have pointing out that I want to adress AMD support, not the community.

So please no "tell me your hardware" etc. I'm just interested in: When get's AMD this **** DONE, FINALLY!!!

Every newer Radeon has NO OpenCL hardware acceleration in Affinitiy Photo! And it is clear, that it is a AMD driver bug.

I had a 6800 and now the 6600XT.  I'm waiting for over a year now, together with MANY others...

And thanks for the Microsoft hint, but that's software emulation, I think.

 

0 Likes
kingfish
Volunteer Moderator
Volunteer Moderator

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

Report your issue to AMD support...(you still have to describe your system).

https://www.amdsurveys.com/se.ashx?s=5A1E27D20B2F3EBB

 

elstaci
MVP

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

@kingfish 

Never seen that AMD Support page before. I bookmarked it for future use with 3rd party software.

elstaci
MVP

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

@Soln 

Sounds more like a Affinity Photo issue rather than a AMD Driver issue.  Affinity Photo developers are the ones that need to make their software compatible with AMD GPU cards and their drivers.

If this issue affects more than just Affinity Photo then AMD should find a fix since it is widespread and not specific to one 3rd party program.

I would be ranting at Affinity Photo Support and not AMD Support.

Soln
Adept I

Re: No OpenCL / hardware acceleration in Affinity Photo for over a year now

... the ball is lying on AMDs ground...

0 Likes