Showing results for 
Search instead for 
Did you mean: 


Journeyman III

No display port signal after driver update RX 470

Hi there,

I have an ASUS Strix RX 470.

The card seems to work fine when windows automatically installs the default drivers (which is version 17.1.1). As soon as I install the latest drivers ( I have tried both 18.5.1 and 18.9.1) the screen just ends up flashing this fuzzy screen and then proceeds to lose signal, this reoccurs after the windows logo when booting (loads into bios just fine). This only seems to cause an issue with the display port, as HDMI works fine, but I can't resort to losing freesync. This is also not a psu issue as all of my other cards including an R9 390 work just fine.

Things I have tried:

-Using DDU to remove drivers and reinstall them (Tried about 10 times).

-Power cycling monitor and PC.

I have looked around and I can't seem to find a solution. If anyone has a possible idea on how to solve this, i'd be very grateful.

Thanks in advance.

0 Replies