cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

jonathan9168
Adept I

NEW RX570 NO AUDIO OVER HDMI

Just got an RX570 for my 2400G and after installing, my monitor speakers no longer output sound. The only way i can get sound is by plugging in headphones. When i removed the gpu and ran off the vega 11, Sound played fine via the monitor speakers. With the gpu, when i go into device manager i notice that AMD HD is missing from sound tab where as it is present when running from vega 11. Ive tried to reset my pc , used ddu and installed drivers again and nothing is working....

79 Replies
edukn
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

It happens exactly the same thing with me, I have an R5 2400g and there is no sound coming from the HDMI of the RX570 gigabyte, this started to occur after I update the F32 BIOS of the motherboard A320m SH2 Gigabyte. I've done everything, formatted Windows 10 3x times, the AMD High Definition Device does not appear in the device manager, with Vega 11 the sound comes out normally in HDMI. I do not know what else to do, I'm desperate!

0 Likes
elstaci
MVP

Re: NEW RX570 NO AUDIO OVER HDMI

Make sure your default Audio device is connected to the GPU card via HDMI or DP.

Go to BIOS and make the RX570 the main Graphic Adapter to boot on. Generally BIOS is set to automatically switch from integrated to Discrete GPU Card when the GPU Card is installed.

Make sure you have the latest RX570 Driver installed. Radeon™ RX 570 Drivers & Support | AMD 

Go to Sound Panel and see if you see your Audio Device is showing. If it is not there right click on any audio device and click on showing " Disabled Audio Devices" and "Disconnected Audio Devices". Now see if it shows.

Most likely your RX 570 Driver was not installed because your APU Integrated Graphics might be the main Graphic Adapter to boot.

In Device Manager does your RX570 appear under "Display".  If it does, are there any Yellow Exclamation marks or Error codes?

What is showing in Device Manager of HD Audio?

0 Likes
jonathan9168
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

https://gyazo.com/361c859a84ad3218d4d3651a0b8a090a (Normal when using vega 11)

https://gyazo.com/1764d13f2f2aa6780b794d97b297928f (Normal in device manager on vega 11)

When gpu is installed, only spear is shown in first pic not the rest and in second only realtek shows not the AMD one too

0 Likes
edukn
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

AMD High definition audio is hidden when RX570 is in use and Vega 11 is Disabled in BIOS, audio over HDMI only works on Vega; All drivers is installed and update.Captura de Tela (3).png

0 Likes
elstaci
MVP

Re: NEW RX570 NO AUDIO OVER HDMI

Can you post an image of Windows Sound Panel with both "Disabled" and "Disconnected" Audio devices showing?

Right mouse click and select "Disabled" and "Disconnected" Audio devices.  You can find Sound Panel under Control Panel and Windows Settings.

0 Likes
jonathan9168
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

Me too

edukn
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

Captura de Tela (4).png

Captura de Tela (9).png

Captura de Tela (6).png

Captura de Tela (10).png

0 Likes
jonathan9168
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

I have the exact same problem. For me it just keeps showing 10.0.1.10 even though i choose the one in the driver update. I just ended up getting external speakers and plugging it into my motherboard.

0 Likes
elstaci
MVP

Re: NEW RX570 NO AUDIO OVER HDMI

The AMD Driver is not seeing the RX570 connection to your Audio device for some reason which is probably why it is not showing in Sound panel. What is strange, it is not even showing up under "Disabled" or "Disconnected" Audio devices. It is as though your RX570 GPU card wasn't even installed and recognized.

In Device Manager is the RX570 recognized and are there any Yellow Exclamation Points or Error messages?

Make sure in BIOS, the RX570 is the main Graphic Adapter used in the computer and not the Ryzen APU Integrated Graphics.

The Realtek Audio concerns your Motherboard's Audio and not the GPU card which would be AMD Audio.

In my Sound Panel it shows both Nvidia and Realtek Audio. Nvidia Audio is anything connected to my GPU card while Realtek Audio is anything connected to my Motherboard that has sound. 

Since the last AMD Driver update many people have been complaining about no HDMI Sound from their GPU Card. Seems like it is a major bug either caused by AMD or Windows update or both.

I suggest you open a AMD Service Request and see what they say from here: Online Service Request | AMD 

0 Likes