cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Adept I
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

Wow. 

0 Kudos
Journeyman III
Journeyman III

Re: NEW RX570 NO AUDIO OVER HDMI

oh wow! Care to tell me which BIOS did you make the update to? I have the exact same problem with my RX 570, but I have a different Motherboard, wanna try if that can solve my problem.

0 Kudos
Journeyman III
Journeyman III

Re: NEW RX570 NO AUDIO OVER HDMI

Thanks edukn! I had to downgrade my bios as well. First I updated from F31 to F32 to see if it get better, but there was no result. So I downgraded it from F32 all the way down to F1 and now it recognize my HDMI Monitor (as audio).


I also noted that, when I had my MB's bios updated, I did not have any Realtek app and when I tried to install one it said that it was not compatible. Now that I downgraded, I got a realtek icon in my tray (Realtek HD Audio Manager), it does recognize my audio codec (ALC1220) and HDMI TV appears (From AMD High Definition Audio Device).


My hypothesis is that somewhere in those bios updates it mess up your audio support or something. If someone can come up with a long term solution (since I am forced to update bios for Ryzen 3000) I would be more than thanksful.

Before:

After:

PS: I have a Gigabyte B450 Aorus Pro Wifi.

Big Boss
Big Boss

Re: NEW RX570 NO AUDIO OVER HDMI

I assume the volume on the TV is cranked up.....

0 Kudos
Esteemed Contributor III

Re: NEW RX570 NO AUDIO OVER HDMI

You all should report your findings to Gigabyte so they can look into it and fix it.

Adept I
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

I was in the F32 version and went back to the F23 version (which came from the factory), my motherboard is the A320m sh2 gigabyte.

Journeyman III
Journeyman III

Re: NEW RX570 NO AUDIO OVER HDMI

MSI B450 Carbon AC is also having the same problem after updating the BIOS.

0 Kudos
Big Boss
Big Boss

Re: NEW RX570 NO AUDIO OVER HDMI

viniciusms wrote:

MSI B450 Carbon AC is also having the same problem after updating the BIOS.

looks like inadequate testing of the new BIOS

most likely there will be another fix posted sooner or later

0 Kudos
Adept I
Adept I

Re: NEW RX570 NO AUDIO OVER HDMI

ASROCK Fatal1ty AB350 itx/ac Mainboard has the same issue.

CPU is also the 2400G but GPU is RX580, still no audio over gpu with hdmi.

Windows and drivers are up to date and bios is 5.6. I had no issues with 5.3, but I can´t downgrade the bios.

Is there a fix?

0 Kudos
Big Boss
Big Boss

Re: NEW RX570 NO AUDIO OVER HDMI

try audio with the sound chip, this seems to work better with windows at the moment

0 Kudos