cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

rezhyn
Adept I

New RX 480 - Low Usage and Performance Issues

Jump to solution

Hello,

I recently purchased an ASUS RX 480 OC to replace a old 660ti. The rest of my system is up to spec for this card (see below) but ive had nothing but performance issues with this card. After an entire weekend of troubleshooting I believe my issues are due to the card not staying at high usage as seen from MSI Afterburner. When I watch benchmark videos or normal gameplay the persons usage stays at 99 to 100% however mine will frequently drop to basically any number whenever it wants. Now I dont exactly see immediate frame drop when the GPU usage drops, but if something happens on my screen like a gunfight or loading parts of the map my FPS will plummet to sometimes 25.

In general I feel my performance is lackluster - near matching my 660ti besides the hard frame drops. CSGO can sometimes go sub 100fps and H1Z1 on same settings as my 660ti can perform worse. If I benchmark on 3D Mark my GPU never drops below 98% usage and the setup scores around 4000 (healthy). Benchmarking on Wildlands I average around 98% GPU usage yet in game dont stay close to that, but the benchmarking results are pretty good.

My PSU is pretty new, my CPU is pretty strong (even tried OC), and 16GB RAM has to be enough. The GPU and CPU temps never go above 70, and my CPU has healthy usage (70-99%). GPU fans work normally. I really need some help figuring out this card and sending it back and purchasing a 1060 if need be.

Things ive tried:

- Reseating the card

- Using different HDMI port

- Overclocking/Underclocking on CPU/GPU

- Disabling power efficiency, setting high performance, maxing power output in Wattman

- Disable ULPS

- Updating motherboard BIOS

- Fresh installing windows/cleaning drives (3 times)

- Tried 10 different sets of drivers, ranging from very old to newest and default Windows ones (used DDU)

- Vsync on and off/different graphical settings

- CPU Core Unparking

- Disabling ReLive and Xbox DVR

- Killing processes of AMD in task manager

- Maxing fan usage and temps to try to stop throttling

- SSD and HDD (both functioning healthy)

- Disabling all background processes

My setup:

ASUS RX 480 OC - Dual fans

i5-4690k @ 4Ghz

16GB DDR3 RAM

Z97 PC Mate Motherboard

EVGA Bronze 600W PSU

NXZT S340 Case with 3 fans

Samsung LED 1080p@60hz monitor

2x 128GB SSD and 1 500GB HDD

EDIT: Ended up getting exact replacement of the card and it looks like all is good - just a hardware issue (fingers crossed)

1 Solution

Accepted Solutions
rezhyn
Adept I

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

I ended up getting my replacement card today, same exact model and viola, issues seem to be gone thus far so looks like it was just a hardware issue. I will look into getting higher speed RAM however - thank you!

View solution in original post

10 Replies
kingfish
MVP

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

First, don't use CS:GO as a example. All graphics cards (Nvidia/AMD) are having issues recently with that game. You should be talking to the game developers. > CS GO crashing/not responding/etc

Do you have your Power Limit set to +50?

ReLive version drivers do not work well with any third party controller...delete/disable them, set graphics back to default.

I see you have multiple HD's. Did you use the default download location? Is the AMD graphics/driver on the same drive as your OS?

0 Likes
warsun
Challenger

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

What driver was this you where using?

0 Likes
ibanggpu
Adept III

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

Whoever solves this issue will get my old ddr3 1600 mhz ram stick that I have blessed with my DNA for good lucks and fortune.

Edit: Tell me your ram speed for your DDR3 16gb ram NOW, RAM speed can bottleneck your performance, doesnt matter how much you have as long as you have 8gb+

0 Likes
rezhyn
Adept I

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

Yes, power limit set to 50 and drivers on my OS SSD.

I noticed yesterday I was able to play Division on maxed settings with no

issues until something happens like a fire turret is placed or a player

comes up to fight me, ill then drop to very low FPS instantly even on

lowest settings. I really dont think this is a CPU issue since im not

hitting crazy temps and all the tests I did came back with healthy results.

0 Likes
rezhyn
Adept I

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

1600mhz dual channel.

0 Likes
rezhyn
Adept I

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

Ive tried nearly all the 16. ones and all the .17 ones especially the newest. Even the default drivers Windows installs.

0 Likes
ibanggpu
Adept III

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

I found the problem. Your ram speed is bottlenecking your system, sometimes even by 100+ fps.

This happens a lot in online games like overwatch,csgo and h1z1 where the games are pumping a lot of data in and out on your cpu and its memory controller relying on your ram speed to complete some operations fast enough.

Take a little look at this thread on the overwatch forums: 64hz tick, and how to gain FPS with new RAM!! - Overwatch Forums

People with beast PCS were only getting 120-150 fps on their game, and when they upgraded their ram speed, they gained  100fps+ from boosting from 1600mhz to 2400 mhz and ran overwatch at 220-300 fps.

Online games are getting more taxing on your cpu memory controller, 1600mhz is considered slow nowadays.

I would recrommend getting 2400mhz+ 8-16gb  ddr3 ram sticks.

Also, make sure you installed your rx 480 on pci express 3.0 on your motherboard or it might power throttl even if you set the power limit to +50%

0 Likes
rezhyn
Adept I

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

I ended up getting my replacement card today, same exact model and viola, issues seem to be gone thus far so looks like it was just a hardware issue. I will look into getting higher speed RAM however - thank you!

View solution in original post

timobkg
Adept II

Re: New RX 480 - Low Usage and Performance Issues

Jump to solution

I'm having a similar issue. Did you RMA your card?

0 Likes