Showing results for 
Search instead for 
Did you mean: 


Adept III

My xfx rx 6700 xt is stuck at running pcie 3.0 x8 speed

I have asus crosshair VI hero wifi x370. when i use my 6700 xt with it. it's lock to pice 3.0 x8 and i had a 5700 xt that ran at pcie 3.0 x16 speeds. i have ryzen 9 3900X cpu i know the MB can only do pcie 3.0 but is there a way to fix the issue im having. i have no m.2 drive. i only have one other pcie card sound blaster z that runs at 1x. i have try taking out the sound card and move my sata drives to different sata ports nothing is working. im running windows 11 pro

1 Solution

i found the problem it was the card it self there was traces on the pcie  that had been cut or not making contact on the card  so it wasnt getting the full 16x lanes. contact amazon to send me a replacement one.

View solution in original post

18 Replies

It's gotta be in your BIOS PCIE peripheral settings under your BIOS advanced control features.

Or you need to update your BIOS to support your new hardware.

I'm running an MSI X370 M7 ACK MOBO which has 3 PCIE x 16 slots.

I'm running the latest BIOS for my board with an RX 6900 XT and I get all 16 pipelines.

Also ensure there are no hardware in your secondary/discrete PCIE slot as this will cause your MOBO to think your trying to run crossfire and default set your Primary GPU slot to the 8 x configuration.

I've heard of some people having this same issue running a WIFI card or other hardware in the PCIE x 1 slot just above the main PCIE x 16 slot if thats the case just shift the hardware to other slots that may fix your issue.

Good luck we will provide further assistance when called upon. 

i have try disabling the built in wifi card it cant be move to different slot but i also use the BT that comes with it. and it stay stuck at 8x when i do im running the latest bios on my MB and have done a clear cmos both ways the cmos button and removing the battery. i could try reflashing the bios or use a older bios that was not windows 11 ready bios by default. i did a reflashing  of the bios and no changes in the bios is still reporting the card running at 8x i have sound card plug in at the last pcie 1x slot and gpu is on the first pice x16 slot i have disable the built in sound card and wifi card. still no change i think it has to do with my asus MB

And when you give the load to the video card, for example, fullmark, or better gpu-z, and from the right of the bus interface a question mark and the start of the render test, does the second value in the same window, next to the question mark, change? Watch this video mb will help

Another User recently opened a thread about the same issue that his GPU card was running at PCIe x16 x8 instead of PCIe x16 x16

Turns out that he had another PCIe Card installed on the second PCIex16 slot on his motherboard thus cutting in half the PCIex`16 slots bandwidth from x16 to x8 in the first slot.

Your Asus Motherboard has three PCIe x16 slots. But most likely the first 2 slots are connected in the respect if you have two PCIe cards installed in the first two PCIex16 slots it will automatically cut the bandwidth from x16 to x8 on each slot.



It didn't help pulling out the soundcard i have. It's not in any of the pcie x16 slots. 


Try to pull out the video card and wipe the contacts on the video card with an eraser (eraser), and insert it again, only carefully.(do not break the key that locks the video card in the slot. disconnect all the paraphyria from the motherboard except for the mouse, keyboard and monitor, and headphones, probably, and check if there will be a result.

Adept I


your card is in the top x16 slot?


20220126_095157.jpg20220126_095205.jpgyes its in the top x16 slot


Have you tried to take out the video card and wipe the contacts on it with an eraser? And reinstall the drivers completely? With the help of amd uninstall utility and reinstall, preferably with a reboot and disconnected Internet, well, and a downloaded draver that you will install)


Alternatively, try downloading a driver for your video card for your windows 11, then using Display Driver Uninstaller to remove the driver, but select installing a new video card, in this case the PC will turn off, and then take out the video card, wipe the contacts with an eraser and reconnect (do not forget about additional power) and preferably disconnect the Internet or simply remove the cable when you turn on the PC, and then manually install the downloaded driver, perhaps the driver or the system did not initialize the video card correctly. Post about the results)


i found the problem it was the card it self there was traces on the pcie  that had been cut or not making contact on the card  so it wasnt getting the full 16x lanes. contact amazon to send me a replacement one.


Good troubleshooting. That is, in my opinion, a fairly rare instance for the GPU traces to be damaged. I am surprised you weren't seeing other symptoms like crashes or BSODs.



one thing was odd was my 5700xt is pcie 4.0 16x card and it ran at 3.0 x16 lanes with no issues. i figure it had to be the card it self. because i have only one other pcie card it its in a pcie 1x slot and there nothing else beside the graphic card. so i put my 5700xt back in for until i get the replacement one. one thing i did was what other people have try nothing was working.

Yes, maybe the card was used. and there was such a strange defect, which, in fact, if you don't check and you won't find out. If you use pci express 4 versions, even x8, then there should be no problems, but in version 3 of x8 there will definitely be problems if the rx 6600 has a drop in performance using pci express version 3, and it works at most x8, in tests with version 4 of pci express, performance is good.(there is enough bandwidth) even on x8. And in other cases, you need to look at the processor, since some amd processors with integrated graphics do not pull x 16, but you need to look at the specification for the processor, you have a motherboard of version 3 and x 16 should work, but the processor supports version 4 x 16. I hope they will exchange your card or refund your money.


the replacement card came in today and it running at 3.0 x16.

Great! I am glad that you have changed the video card, and the problem has been solved)


This is actually a fairly wide spread issue with Vega 5000 and 6000 series GPU's on Windows 11. 

Most of the people I've checked on report running Asus Asrock or Gigabyte MOBO's

I went on YouTube and typed in problems with windows 11 PC's throttling AMD GPU to 8 pipelines. Wow their is a lot of them.

Some Intel and MSI MOBO users have reported similar occurrences it's even affecting Invidia 2050 2060 and 3050 and 3060 GPU's

I'm just tossing out a guess but it sounds like Microsoft could be the main problem.

Doesn't mean we won't be able to find a workaround and get your PC to full throttle.