cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

slyr101
Journeyman III

My intel graphics is being used over my Radeon RX 580

I recently bought the CYBERPOWERPC Gamer Xtreme GXIVR8020A4 Desktop Gaming PC and I have a problem where games recognize my inegrated intel graphics over my dedicated Radeon RX 580.

I have set my windows power settings to 10

After uninstalling both drivers then using DDU and then reinstalling my drivers problems persist

My Amd radeon settings do not have any form of switchable graphics settings and there is no display connected to my amd

I have tried disabling my intel graphics through device manager but that makes microsoft basic render be detected instead of my radeon

Interestingly Rainbow 6 siege can use my graphics card because I forced it to in it's own steam files so I know my radeon works somehow however since other games don't let me mess around with their own files I can't do the same for them. For instance total warhammer 2 only detects my intel 630HD graphics, all other games like dota 2, starbound and rimworld also have this problem (literally every other game besides rainbow 6 siege).

I have tried changing my bios however when i set my graphics from cpu graphics to pcie or auto it just resets when I restart my pc however all other options in bios don't reset only the graphics settings.

This problem occurred before the most recent windows update so I don't believe it could be caused by that.

Desktop

Radeon Software Version - 18.2.1

Radeon Software Edition - Adrenalin

Windows Version - Windows 10 (64 bit)

System Memory - 8 GB

CPU Type - Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz

Radeon Settings Version - 2018.0131.1849.33856

Driver Packaging Version - 17.50.17.03-180131a-323831C-RadeonSoftwareAdrenalin

Provider - Advanced Micro Devices, Inc.

2D Driver Version - 8.1.1.1634

Direct3D® Version - 9.14.10.01316

OpenGL® Version - 6.14.10.13506

OpenCL™ Version - 23.20.15017.3010

AMD Mantle Version - 9.1.10.0237

AMD Mantle API Version - 102400

AMD Audio Driver Version - 10.0.1.6

Vulkan™ Driver Version - 2.0.1

Vulkan™ API Version - 1.0.65

Graphics Card Manufacturer - Powered by AMD

Graphics Chipset - Radeon RX 580 Series

Device ID - 67DF

Vendor ID - 1002

SubSystem ID - C580

SubSystem Vendor ID - 1682

Revision ID - E7

Bus Type - PCI Express 3.0

Current Bus Settings - PCI Express 3.0 x16

BIOS Version - 015.050.002.001

BIOS Part Number - 113-58045HED1-W91

BIOS Date - 2017/04/10 23:39

Memory Size - 4096 MB

Memory Type - GDDR5

Memory Clock - 1750 MHz

Core Clock - 1366 MHz

Total Memory Bandwidth - 224 GByte/s

Memory Bit Rate - 7.00 Gbps

2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001

0 Likes
3 Replies
slyr101
Journeyman III

Re: My intel graphics is being used over my Radeon RX 580

I don't know my specific psu but i know its about 150 watt. If this is a psu problem then i'm getting a 500 watt psu soon so hopefully that resolves this if nothing else does.

0 Likes
goodplay
MVP

Re: My intel graphics is being used over my Radeon RX 580

You should contact Cyberpower support, while still under warranty.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes
av3r4g3
Journeyman III

Re: My intel graphics is being used over my Radeon RX 580

Your HDMI needs to be connected to the PC, I know I've been there, I just figured it out today that your HDMI needs to be connected on the actual graphics card to be automatically set to default, go in the back and look in the middle if you see red plastics things pull them out and that's where the HDMI slot goes. Hopefully this fixes the issue.

0 Likes