cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

kagetsuki
Adept I

Linux: RX 5600XT problems with Display Port when using OSS modules/drivers

* Pretext: I'm not entirely sure if this issue is specific to the OSS modules as I'm using Ubuntu 20.10 and the "Pro" packages do not currently support it. I'm sure this is Linux specific as the problem does not occur in Windows.

* Related post on Ask Ubuntu: https://askubuntu.com/questions/1295100/screen-does-not-turn-off-and-random-freezes-with-radeon-oss-...

Using Ubuntu 20.10 [running with the Ubuntu supplied 5.8.0-32-generic kernel at the time of writing this]: when I have any display connected one of the Display Port ports on the back of my Sapphire RX 5600XT the displays will not blank [turn off] when I lock the screen. When the screen lock is activated, the screen will attempt to blank and will turn off for a moment; then will turn back on. However, occasionally when attempting to blank the system will freeze. The system will also freeze maybe half the time when waking the system up from suspend. I have also found that turning a display attached to a DP port on and off will occasionally freeze the system.

The system is completely frozen when this occurs, and there is never anything relevant recorded in /var/log/syslog.

The problem does not appear when only using the HDMI port on the card/not using any of the Display Ports on the card.

I believe this is a kernel module issue so I'll try and build a kernel of my own with the latest amdgpu OSS modules for now, but if anyone has any idea how to resolve this issue in some other way I'd love to know. Or, if there's anything someone can suggest to try and accumulate error/debug data on this issue, or if there's somewhere I should be submitting a report for the amdgpu OSS module developers, please let me know.

0 Likes
2 Replies
kagetsuki
Adept I

*UPDATE* The issue is NOT due to DisplayPort, but rather the issue seems to have something to do with multi-head, and can be replicated easily.

If only one display is hooked up to the card there are no issues - the display blanks and goes to sleep properly and turning on and off the display does not cause any problems, regardless of which port the display is connected to.

If more than one display is hooked up to any of the ports on the card the displays will no longer sleep, and turning off and on any display will instantly freeze the system.

This problem persists with the OSS amdgpu module on the latest official Ubuntu 20.10 5.8.0-32-generic kernel. The problem occurs with both gdm3 and lightdm, and on both wayland and xorg, and on Gnome and other desktop environments. I have tested with both Acer and Mitsubishi displays, and have tested 2 different brands of DisplayPort cables. So I'm 99% sure the issue has to do with either the amdgpu module or how Ubuntu is integrating the module/patches into their kernels.

If there's some way to get in touch with an official maintainer of the amdgpu module so I can assist in fixing this issue please let me know.

0 Likes

*Follow-Up Update*

It *does* still freeze up with one display attached to a DP port. Switching back to only having one HDMI display attached to the card and will update if I encounter further freezes. If anyone has any ideas how I can diagnose this in more detail, EG if there are some hidden logs somewhere or some debug flag I can enable, PLEASE let me know.

0 Likes