Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Issue Macbook pro 16 with eGPU and MSI RX 5700XT and bootcamp


I contact you because I'm very sad.

I bought a razer core x chrome with an MSI RX 5700 XT.
I plugged it into my 16 inch Macbook Pro with AMD PRO 5500 4GB.

The problem is that the RX 5700 XT is visible in the device management but is absolutely not usable. It has a warning on it. Even if you turn off the 5500, reboot, update the drivers etc., the 5700 still doesn't work.
It's very frustrating because when I test with a GTX 1060 I don't need to do anything at all, everything is recognized automatically.

I think Windows recognized it one time and windows update downloaded automaticly this 3 drivers (in attachment), after that, I had a black screen and the only way to work it again was to boot in safe mode and delete recent update

Does anyone have the same problem or have an idea how to make it work?

Thank you very much for your help.

8 Replies
Journeyman III

same issue with macbook 15 2019 i9, razer core X, radeon RX 5700XT sapphire nitro+:

Microsoft doesn't know what to do....

Apple says: once you're in windows we are not concerned...

Razer: if it works on mac osX we don't care...

What does AMD would say....?????

The only solution seems to be an obscure process which can destruct your mac!

But with a combination of uninstall reinstall, I had the 560X and te 5700XT worked, but one reboot and the magic was gone....and same issue.....

I'm not sure but I think that a simple method to keep it working after a reboot should be an easy game for AMD, apple, microsoft, or razer ingineers...

sorry for my english I'm french....some words might be frenchenglish....;o)

#macbook pro


#egpu boot camp

#macbook pro egpu boot camp

Adept I


I also have a Macbook pro 15 2019 and i'm looking to buy a eGPU. i have read that the Razer core X with a AMD radeon RX 5700 XT a good combination is to boost your performance. Now i was searching the websites of Razer and AMD to see the Specs of both hardware and there i found that the RX 5700 XT needs a PSU of 600W (recommended)

PSU Recommendation
600 W

on the website of Razer says that the core x only gives 500W

GPU Max Power Support

    500 Watts

doesn't the 100w shortage doesn't give any performance problems or overheating problems?

thanks for helping

with friendly greetings


Adept I

Are you still having this issue? 

I have MacBook Pro 16" Core i7 32GB and eGPU enclosure with 5700 XT. 

Works pretty well via bootcamp on latest Win10 1909


Hello, I just got my setup and I am not happy.. It works great in macOS but I got this for bootcamp so I can work on animation.  I been fighting this for 2 days and I am so close to sending it all back to amazon.   Someone needs to take control on these driver issues.  

What did you do kokaruk to make it work?  I have the caution yellow thing on the driver in device manager.  

thank you for your help.


Welcome to the club mate. 
I've had exact same frustration at amd for not providing support for people like us. 

It seems like customer support is not what they do. 

You need to install custom build drivers pack. Basically these are original amd drivers with removed compatibility check. 

By far the best place to get these are at "botcamp drivers . com"

Try that, see how it works for you. 

Thank you Sir!    I will check it out and get back to ya on the results!  Cheers!!!!!


How do you install drivers when the eGPU won't allow the display to turn on.  I posted a new thread on this.  I went to Update AMD drivers on the windows side and first it uninstalled the older drivers causing a black screen.  Now I can only boot in with the eGPU disconnected.  Thanks!


leaving the exact URL for the people facing same issue.

AMD should remove the system check if they cannot make it proper. Windows running on my MacBook 2019 15-inch recognizes the RX5700XT, connected via Razer Core X Chroma, on Device Manager and the AMD drivers are automatically applied by Windows, but the AMD Adrenalin 2020 aborts the installation with "Error 173" with saying that AMD graphics hardware was not detected in the system configuration.