cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

arnatzzz
Adept I

Integrated GPU is using too much ram.

Jump to solution

Right now I have 8GB of ram on my laptop and 2.1GB is used for hardware reserved. And I found out 2GB is used for my AMD Radeon(TM) RX Vega 10 Graphics memory. So that made my ram only 5.94GB usable. I have GTX1660ti, So I want to use as much ram as possible for the best gaming performance. I tried lookup in bios but there are no graphics settings. I tried the registry editor method. Neither worked. Is there any way to fix this problem or decrease dedicated video memory besides upgrading my ram. I want that to be my last option. Thank you.1.png2.png

0 Likes
1 Solution

Accepted Solutions
arnatzzz
Adept I

Re: Integrated GPU is using too much ram.

Jump to solution

Sorry for the late reply. I did solve the problem. After updating the latest bios, there's an option to choose how much ram to be shared to the iGPU.

I hope this reply isn't too late.

View solution in original post

0 Likes
13 Replies
mstfbsrn980
Grandmaster

Re: Integrated GPU is using too much ram.

Jump to solution

It is normal for your IGPU to use 2GB of RAM. If it uses 1GB of RAM, VRAM will not be enough for new games. GPU VRAM setting may be within the BIOS. Refer to the BIOS settings or motherboard manual. But no need any changes.

arnatzzz
Adept I

Re: Integrated GPU is using too much ram.

Jump to solution

I forgot to mention that I have gtx1660ti on my laptop. So I want to be able to use as much ram as possible for better gaming performance.

0 Likes
mstfbsrn980
Grandmaster

Re: Integrated GPU is using too much ram.

Jump to solution

If the laptop has a GPU, then this is of course not normal.
Is this RAM problem corrected by BIOS? How to fix it? I do not know...

elstaci

0 Likes
elstaci
MVP

Re: Integrated GPU is using too much ram.

Jump to solution

Can you post the exact Make & Model of your Laptop?

Normally in a Desktop BIOS you can adjust the amount of RAM Memory that can be dedicated to the APU integrated Graphics. Anywhere from less than 1 gbyte to a maximum of 2 gbytes of RAM Memory.

Now as for a Laptop BIOS, I guess depending on the manufacturer, may have that option in BIOS settings (as mentioned by mstfbsrn980)   but not really sure if it does or not until I know the Make & Model of your laptop.

For your information on how to update and configure your Switchable Laptop from AMD Forum:

Update Laptop AMD Drivers: Laptop graphics update...How to 

Configure your Laptop Switchable Graphics: https://www.amd.com/en/support/kb/faq/dh-017#SGApplication 

arnatzzz
Adept I

Re: Integrated GPU is using too much ram.

Jump to solution

My laptop is Asus Zephyrus G (ga502du)

0 Likes
elstaci
MVP

Re: Integrated GPU is using too much ram.

Jump to solution

Here is where you can update all your Asus laptop drivers from Asus Support: ROG Zephyrus G GA502 Driver & Tools | Laptops | ASUS USA 

I would suggest to update your Nvidia and AMD graphics drivers and CHIPSET (which includes the AMD Graphics driver) and also to be sure you have the latest BIOS version installed (Version 208).

I downloaded the manual from Asus for your laptop and it is not very helpful as to the various BIOS settings or anything to do with the laptop's graphics in general.

Seems like your best bet is to upgrade the laptop's RAM MEMORY but before you do that I would suggest to open a Asus Live Chat or open an Asus Support Ticket and see what they recommend.

elstaci
MVP

Re: Integrated GPU is using too much ram.

Jump to solution

Looking at your Asus Features from Asus.com you have a program called ROG Armoury Crate where you can configure your GPU and CPU performance: https://www.asus.com/us/Laptops/ROG-Zephyrus-G-GA502/Features/ 

0 Likes
alexrivus
Adept II

Re: Integrated GPU is using too much ram.

Jump to solution

Hey there! I've got MSI Alpha 15 with VEGA10 and had the same problem. This is how I fixed it.

1) Press Right Shift+Right Ctrl+Left Alt+F2 and you'll see "hidden settings"
2) Open "Advanced" tab  and go for AMD CBS ---> NBIO Common Options ---> GFX Configuration 
3) Put the settings like this:


Integrated Graphics Controller                           [Force]

UMA Mode                                                         [UMA_SPECIFIED]

UMA Version                                                      [Auto]

UMA Frame buffer Size                                      [amount of RAM you want for APU] I recommend 512mb to 1gb.

UMA Above 4G                                                   [Disabled] or [Auto] I chose to disable it. Up to you what to do here.

NB Azalia                                                            [Auto]

Your BIOS could be a bit different but the names of those settings should be similar. I wouldn't recommend you to low it down to 256, but it's up to you to experiment. 

photo_2020-05-12_00-15-45.jpg

0 Likes
akramesg
Journeyman III

Re: Integrated GPU is using too much ram.

Jump to solution

I have the exact same issue my laptop is Asus tuf fx505 and can't find anywhere in the bios to set the internal GPU memory, did you manage to solve your problem yet!?

0 Likes