Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Installation of the Radeon RX560 driver in a Windows 10 Professional VM on a KVM hypervisor fails.

Host hardware:

   ASRock X370 Killer SLI

   AMD Ryzen 7 1800X

   AMD Radeon RX 560 (passed to Windows guest)

   16GB RAM

Host OS: Ubuntu Server 18.04 (amd64) with KVM (latest updates installed)
Guest OS: Windows 10 Professional (amd64)

PCI Passthrough is successful and a previous installation of the RX560 driver worked successfully for almost a year. The use case is basically an engineering office using Ubuntu workstations to improve internet security and virus vulnerabilities. For certain packages (such as accounting and 3D CAD), a Windows 10 pro vm is used, which is accessed remotely using RDP. The AMD GPU worked like a charm even though the RX560 is a relatively inexpensive card. After applying some upgrades on Windows, the CAD system stopped utilizing the GPU (even though the GPU was listed in the Windows 10 task manager performance window - doing nothing). As a possible solution, the latest driver was downloaded from AMD, and after trying to simply install the latest driver, the installation would hang half way through. In an attempt to avoid this, the tool to clean up existing installations was used to completely uninstall the previous driver (and reboot), but the installation still froze with the only option remaining to reboot the guest. After a reboot, the software seems to be installed, but the GPU does not show up in the task manager.

The card is connected listed under a separate PCI group, which allows for pass through. Problems memory addresses partially locked by Linux was solved a long time ago and the effect was that the guest would not start up properly - this is not the case now.

Is there any way I can obtain a log of where the driver install fails, or how I can get passed this issue?

0 Replies