cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Rhype
Journeyman III

I think that my gpu AMD RX 5700 XT is underperforming

Hello guys, im not an expert into pc stuff but i can notice that my gpu is underperforming. I have an Intel i5 9600k cpu and 16gb of ram. when i try to play games i see unstable fps. For example when i try to play league of legends my fps keep dropping to 100 into fights when my 2 other friends maintain 240 with the same exact pc build. In fortnite i have massive stutters,  cant get over 200 and have massive drops from 180 to 30 for a sec.  i tried clean installing the drivers but it didnt change a thing. Thats my problem hope someone has a solution for it because its really frustrating thanks in advance!

0 Likes
19 Replies
blazek
Volunteer Moderator

What graphics settings and resolution are you gaming at?

0 Likes
Rhype
Journeyman III

it doesnt seem to matter because me and my friend who has teh exact same specs play on the same setting and his performance is far superior 

0 Likes

Got similar issues with my 6900xt.

Already posted on the Forums and i tried pretty much every troubleshoot step i can think of.

0 Likes

ahh man that is so sad ...

0 Likes

@Rhype hello there. I am sorry to hear that you are having these issues.

I would start by monitoring a few things while playing, in order to figure out what is going on:
- CPU temperature
- CPU load (for each individual core)
- GPU core clock
- GPU memory clock
- GPU load
- GPU temperature for core/memory/VRM and hot spot temp
- GPU memory usage
- GPU fan speed
- system memory usage

I suggest you download GPU-Z (freeware) and use the sensors tab.
To monitor your CPU cores, use windows task manager performance tab.

If you do not know what all these values mean, you can post a screenshot here.
I suggest you post a screenshot of GPU-Z's sensor tab after ~5 mins of gameplay.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Rhype
Journeyman III

these are the results i got                                                                                     dsadsa.gifas.gif

0 Likes

screenshots are 100% showing that your GPU is still idling:
- not even leaving deep sleep power saving mode
- GPU clock is way below the first 3D power state (800 MHz)
- memory clock stays 100% on idle (200 MHz instead of 1750 MHz)

Did you capture these screenshots on idle desktop/browser usage?
Or did you start and play a game (more than opening games main menu)?

I need to see what ingame / gameplay performance looks like.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Rhype
Journeyman III

im playing league for like 5 hours now and i was in game the moment i got the photos like 10 minutes in

0 Likes

okay, I see. Thanks for clarification.

Had another look at your CPU: Intel i5 9600k has integrated UHD 630 graphics processor.
My current best guess is that your Windows operating system decided to run the game on that instead.

Please try this:
1) click on the windows-icon in the task bar and type in "graphics"
-> this should bring you to system settings > graphic settings (after clicking on the first option)

2) try to add your current game to the list by searching for it
-> navigate to the folder where your game is installed and select the executable (*.exe)

3) now after adding the game, click on the new list entry (name of your game with symbol next to it)
-> click on the "options" / "settings" button
-> see if you can select "high performance - GPU: RX 5700 XT"

4) restart your game to apply these changes and see if that helped
-> and if it does help, repeat for all other games you want to play 
-> and maybe even have a look into power saving plans (windows energy saving features)

--
oh and just to make sure: do you have your monitor connected to the RX 5700 XT directly?
Make sure you do not have your monitor connected to the mainboard's HDMI/display port.
-> look at the back of your PC, follow the cable from the monitor and make sure its connected to the GPU

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Rhype
Journeyman III

i tried these like 4 hours ago and it didnt change a thing sadly i dont know about the power saving mode tho

0 Likes
Rhype
Journeyman III

thats a screenshot when im in game in fortnite for example.                  new.gif

0 Likes

Do you have your monitor connected to the RX 5700 XT directly?
Make sure you do not have your monitor connected to the mainboard's HDMI/display port.
-> look at the back of your PC, follow the cable from the monitor and make sure its connected to the GPU

- the mainboard connectors are on the far top/left area - next to all the USB ports
- the GPU is more towards the bottom of the PC with several display ports and one or 2 HDMI ports on it.

If you have it connected to the mainboard then games wont use your GPU at all.

---
Your GPU is not really utilized in your screenshots, so this might not be an issue with power saving.
I rather think it is not used for rendering the game at all. Since memory clock should ramp up for the 3D game at least.

---
That GPU-Z screenshot while playing Fortnite at least shows higher core/mem clocks and GPU usage.
But that is still within power saving mode - and not full 3D power (non energy saving mode).

Do you have the PCIe 8pin & 6+2pin connector connected correctly?
Your GPU needs both of these to be connected - double check inside your PC if they both fully connected.
-> depending on your Power Supply its either 2 cables with 8pin connector each
-> or a single cable daisy chained with 8pin and next to it a 6+2pin

---
@Ray_AMD @Ashley_AMD 600 seconds timer for "post flooding"? Can we decrease that to 5 mins? Please? (O_O)'

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Rhype
Journeyman III

i do have the hdmi connected to my monitor (its a tv monitor kinda crap) and i checked the pins they are correctly connected ( the gpu has one 8 pin and one 6 pin slot) btw thank you for trying to help me out appreciate it a lot.

0 Likes

Please post 3 more GPU-Z screenshots, but this time from:
- "Graphics Card" tab
- "Advanced" tab -> and select "general" (from the drop down list)
- "Advanced" tab -> and select "PCIe Resizeable BAR" (from the drop down list)

Also please click the Windows Logo on the Taskbar again and type in "dxdiag" and click on that.
Let the green loading bar within that window complete and switch to the "display" tab.
-> check if the "Direct X Features" are all enabled
-> see if there are any error reports in the text field at the bottom

---
I also want to suggest a step by step clean driver install:
[clean install guide] - driver update - DDU - clean registry - sfc scannow 
This guide can help to clean up leftover registry entries and prevent Windows Update from installing wrong driver.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Rhype
Journeyman III

i also checked the dxdiag and everything seemd fine all 3 were enabled regarding directx should i try the clean install of the drivers?1.gif2.gif3.gif

0 Likes

All the screenshots are looking good, as far as I can tell.
From these screenshots I don't see a reason why your GPU is not boosting.
GPU-Z is correctly reading all the possible boost values from your vBIOS.
Yet your GPU is stuck in power saving mode while playing games.

some ideas:
- Do you have access to another monitor? Could help to try if it somehow messes with your GPU.
-> try to connect another monitor if you can and see if that changes anything at all
- clean driver install can fix a lot of problems, but in this case I think the issue lies somewhere else.
-> the fresh driver install only takes about 10 minutes - can not hurt to try that if you want to.
- check Windows Energy Plan settings and see if you are using the "high performance" one.
-> and maybe even edit your current Energy Plan and disable PCIe power saving features
-> you can do this by clicking on the "advanced energy settings" within the selected Plan.

--
Sorry for asking this again: are you 100% sure that your HDMI cable is connected to the GPU?
Make sure it is not connected to the HDMI port next to all the USB ports. And please confirm this again. Thanks. 

I am all out of ideas for now. Maybe someone else will read through this topic with more ideas.
I will let you know if I come up with anything else that could help.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes
Rhype
Journeyman III

Thank you buddy I'll try these I'm buying a new monitor in the next few days so I'll try that too I'll update if anything changes thank you so much again!

0 Likes

Did you ever fix this problem? i run similar specs to you and I also have have fps drop to 100 after a few min.  https://www.userbenchmark.com/UserRun/53854909

 

0 Likes
BloomTherapy
Journeyman III

Neither of us seems to mind because we play in the same setting and he performs much better than I do

0 Likes