cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Virtuanaut
Adept I

HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

This is what i posted on HP community:

Finally the reverb G2 reached me. But no luck, it wont work on my system (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT). After connecting error 7-14 memory management, then no bootup at all/system stuck, windows even in broke mode. Tried everything, that is: Win-update, Driver deeinstallation even with DDU, latest driver from AMD (v12-1), USB powermagament off, powermanagement in BIOS with C1 off, BIOS update in Mobo and graphics, tried all USB-Ports, even powered USB-Hub. After that it was possible for one time to launch hp setup of the reverb g2. But at startup wmr BSOD again. BUT: changed to my older PC (Z77A-GD65, Intel Xeon E3 1245 v2, NVidia 1070) the G2 would run without a flaw and even without config, so unit works / no hardware fail. But i want to run it on my new shiny and lighning fast AMD system, which fails. I suspect USB driver problems, since PC runs with reverb plugged into displayport without usb-connection. Please verify and solve this huge problem on newest hardware. Greetings to all with the same or other probs.

0 Likes
30 Replies
tetrodoxin
Journeyman III

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

Same problem here! X470 ROG Crosshair VII, Ryzen 5950X, Radeon 6900XT. Instant bluescreen (memory_management) as soon as both DP and USB of the Reverb G2 are connected.

Swapped the Radeon with an older GTX 1080 Ti (otherwise, same system), no problems there.

Virtuanaut
Adept I

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

(this is what i wrote to HP, plz change hp for AMD...)

ok guys, want to give you an update of that crappy piece(s) o sht

I ordered an usb card allegly helping to speak mandarin or whatever to that hp binos: in a german video they said the inatek card with fresco logic chipset should bring ease. no help. but a real piece of chinese craftmanship, i suspect a condensator to be broken off - not my fault. it kinda worked but u wouldnt trust it too with "cold soldering" in place where a condensator should be... there was another point of soldering that made me suspicious. so i wouldnt recommend to go for that one.

So i ordered the next card, this time a renkforce (kinda no name label over here in the old europe. sry but i never would have figured that i would support that view on us by ole don rumsfeld - in the end he is right... thx to angie, the kaiseress without cloathes hehe). Ok that one looked build well back in the land of the middle, and it has a renesas chipset, 72020 i think, but i didnt verify on assembly - now it is in there. it says renesas in the device management console anyways. ok, the big moment... Boot up, hopes rise. no crash, great. Firstly i used it with a powered hub and without powered headset. that didnt do it. so powered the glasses as well by their own powersource and tada, glasses recognized. BUT i had not plugged in the dp cable yet. For this joke i even bought a separate dp cable with 8k 1.4 specs (to fool the graphics). Glasses send me a one finger salute with 7-14 comment. Ok byebye dp cable, plugged reverb into the 5700xt directly AND U WONT BELIVE IT !!!! sry  - of course BSOD again. But so far i changed my mind and am now convinced, that it is the bloody graphics card that discriminizes the reverb g2... USB really doesnt seem to be the reason for crashing.

And to you, my friends of AMD, listen up: i am working as a doctor in times of corona every day, hadnt a day of sick leave last year, drive about 2,5 hours a day AND spend HOURS for fixing your device in that small time that is left of the day. I dont give up that easy since i started games and especially simulations (for which i bought the reverb) back in the days of c64.  And i think id deserve a plug not pray device for the bucks. I will tell AMD as well, no mistake bout that (here i go). But when i look at all the messages here and elsewhere i feel like doing YOUR job. So a little appreciation would be nice. No, i didnt call for a chat with one nice hp guy/girl/diverse yet, maybe later. But if you had an solution to offer, i guess you would have provided it to me.

To all others, keep on trying and plz post if you made advances in that matter. Greetings from the eifel mountains and a happy new year (anyways)!

elstaci
MVP

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

According to other threads concerning the HP Reverb VR set, AMD has acknowledged that they have a known problem with this specific VR set.

I just took a look at the latest AMD Driver for the 5700XT and it mentions that the issue with HP Reverb has been fixed: https://www.amd.com/en/support/kb/release-notes/rn-rad-win-20-12-1

Radeon Software Adrenalin 2020 Edition 20.12.1 Highlights Support For

  • Radeon™ RX 6900 Series
  • Cyberpunk 2077™

Fixed Issues

  • Gaming applications can sometimes get stuck running at lower than expected graphics clocks on Radeon RX 6800 series graphics products.
  • The HP Reverb G2 VR headset may fail to sync or may have a black screen when run with Radeon RX 6800 series graphics products.
  • Tom Clancy’s Rainbow Six® Siege may experience corruption in Hybrid Graphics scenarios when using the Vulkan API on an extended display.
  • Crossfire™ may experience issues when attempting to change the games resolution to a 16:9 ratio.
  • Performance Metrics Overlay and the Performance Tuning tab incorrectly report higher than expected idle clock speeds on Radeon™ RX 5700 series graphics products.

 

DanBen
Journeyman III

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

It hasn't been fixed for others at least not 7-14 and other related issues with x570 chipsets (see link) as well as with B550 chipsets ( see link). HP officials says that they are still investigating this with AMD (see link).

I would like to know what's is the outcome so far ?


marcoschaap
Adept II

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

BSOD's haven't been fixed either. Somebody on Reddit replied to me and states he doesn't have issues with a reference model 6900XT and G2 HMD. As my 6900XT your 5700XT is also not a reference model guessing by the Aorus? 

Link: https://www.reddit.com/r/WindowsMR/comments/kxxkpz/6900xt_reverb_g2_issues/

I filed a bug report and there's already someone looking in to it. I hope it'll get fixed soon.

tshrimp
Adept I

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

Same issue as many of you all. Plug in the HP Reverb G2 Display Port, and then to the USB3. The Windows Mixed Reality software launches, and right as video is about to go the the headset my computer reboots. 

System is an X570 MB (Asus Prime Pro), Powercolor 5700xt, CPU 3700, 32GB Ram, M.2 HD.

Have tried the following and sure I am leaving some things out.

  1. Change PCIE from 4 to 3 
  2. Tried add-in powered USB 3.0 card (using motherboard USB 3.0, front USB, and USB-C did not seem to work much at all, so continued on with the add-in card)
  3. Uninstalled AMD chipset and GPU drivers and installed back (Also, used DDU for uninstall later)
  4. Installed all latest drivers for the chipset and video card
  5. Tried older drivers
  6. Validated Windows 10 was 100% up to date
  7. Tried external powered external USB 3.0 hub to the MB USB 3.0, and acted like the add-in card. Plug in the USB cable of the headset, MWR launches, and as soon as video looks like it will start...reboot.
  8. Tried fresh install of Windows 10 on a new hard drive. Installing only all Windows updates and latest chipset and GPU drivers from AMD.
  9. Disabled XMP for my memory
  10. Updated BIOS
  11. Tried all Display Ports on the video card.

Looking at the memory.dmp file I see the below, which looks like a driver issue from AMD. I have truncated some top reduce size, so if anyone wants the entire error let me know.

MEMORY_MANAGEMENT (1a)
    # Any other values for parameter 1 must be individually examined.
Arguments:
Arg1: 0000000000004477, A driver tried to write to an unallocated address in the
	user space of the system process. Parameter 2 contains the
	address of the attempted write.
Arg2: 0000000174ad4bb8 Arg3: 0000000000000000 Arg4: 0000000000000000
.
.......

TRAP_FRAME:  ffffd481b55249d0 -- (.trap 0xffffd481b55249d0)NOTE: The trap frame does not contain all registers.Some register values may be zeroed or incorrect.

.........
iopl=0         nv up ei pl nz na pe nc
amdkmdag+0x1c366d5:
fffff806`259c66d5 884878          mov     byte ptr [rax+78h],cl ds:00000001`74ad4bb8=??
Resetting default scope
YMBOL_NAME:  amdkmdag+1c366d5

MODULE_NAME: amdkmdag

IMAGE_NAME:  amdkmdag.sys

STACK_COMMAND:  .thread ; .cxr ; kb

BUCKET_ID_FUNC_OFFSET:  1c366d5

FAILURE_BUCKET_ID:  0x1a_4477_amdkmdag!unknown_function

I also called HP, and worked with them (They were surprisingly good to work with), they stated the issue is occurring when the AMD 5700 xt addresses the CPU the crash occurs. 

I emailed AMD, however, I have not received a response yet :(. 

Virtuanaut
Adept I

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

Hello guys.

I thank you all for participating and replying and want to give a little update on my efforts. Took the time and changed graphic cards between PC's: aorus 5700 xt flew out of the new rig and into the old i7 in exchange for an nvidia 1070 which went into the new rig (aorus 570 board). Results are: new rig (570) works with 1070 and reverb G2! BUT old rig recognizes HMD reverb g2 and crashes when HMD is inserted. So its the 5700xt and/or drivers! Unfortunately the 1070 lacks power for the HMD (which i have to test, did just the proof of concept). I thought that might interested (correctly? dunno) you.

Greets

Stefan

mackbolan777
Forerunner

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

It's an unfortunately wildly known issue at this point. There's several threads on here with regards to AMD RX 6800, 6800 XT, 6900 XT and various VR's not working. HP, Valve, none seem to work properly or at all and like you said, HP confirmed it's AMD's issue. Will they fix it? Hopefully or there will be many going to the Green team. Personally, I don't mess with VR, just 32" 1080p, so no issues thus far with my RX 6800.

Thanks for doing work with Covid, that's a far worse worldwide problem. Stay safe!

"It worked before you broke it!"
tshrimp
Adept I

Re: HP Reverb on AMD PC (570 Aorus Elite, Rizen 3700, Aorus Rx 5700XT) not working

I received a response from AMD on 1/21 asking for some information and that they would be sending to upper level support. I sent the requested info to them the same day, but still waiting. Is it typical for AMD to take this long? My confidence in AMD is dropping fast. When video cards are available, my preferred choice of 6800xt is switching to 3080. I went from an Nvidia 1070 to this 5700xt, and now wishing I would have stuck with Nvidia. Customer service is typically how I decide who I am loyal to, and this isn't helping AMD much :(. I may be past my return window for my Reverb G2.