Showing results for 
Search instead for 
Did you mean: 


Adept II

HDCP disable

Any tips on how to get HDCP working on my system?  When I look at my settings in AMD Radeon Pro under my monitor it shows "Current HDCP Status: Disabled".  I've tried different driver sets including 18.Q3, 18.Q3.1, and even the Adrenalin Edition Beta for Windows October 2018 Update drivers.  I'm using the DP port to connect directly to the monitor.  I know my DP cable and monitor support HDCP because when I boot my PC using the Intel HD graphics, everything works fine.  Any suggestions?  Below are my PC specs.

Dell OptiPlex 7040



AMD Radeon Pro WX 3100

Windows 10 1809 (17763.1)

1 Solution

Looks like a regression on AMD driver side. This issue is being investigated.

View solution in original post

61 Replies

I don't have Amazon Prime, but just movies I have purchased on my Amazon account. The last one I tried was Jurrasic Park, but I believe the issue is any movie I have purchased in HD or 4K quality.  


I just tested a WX3100 / Win 10 / 19.Q1.2 / 4K Monitor / DP Connection. I can play any HD or 4K content on Netflix or Amazon Prime.


Yes I use Display Port monitor 1.2 so no HDCP2.2 and I can use Netflix. Having said that 4K UHD is not available as that requires DP 1.4 monitor. My monitor does HDMI HDCP2.2 and that works in NETFLIX at 4K UHD but overall colour and framerate on Netflix is pretty poor.Waiting to buy a DP 1.4 monitor when I can afford one.

  • Which GPU?
  • Which OS?
  • Which Driver?
  • What is the color depth set to, 8bpc or 10bpc?
  • Does your monitor support HDR?

I think the different between your system configuration and mine is that my monitors are only DisplayPort 1.2.  I realize DP 1.2 is not HDCP 2.2 compliant, which is preventing me from streaming HDCP 4K content.  Even in the referenced Roku article, it says if your display is not HDCP 2.2 compliant, 720/1080p content can still be streamed.  

At the end of the day when I use the Intel integrated graphics (HD 530) I have no HDCP errors in Vudu or Amazon.  When I reinstall the WX 3100, I get the errors.  I'm using the same cables and monitor in each configuration.  The only thing that changes is whether I connect to the DP port on the WX 3100 or my motherboard.


Send me the EDID of your monitor, so I can check


Where can I find this?




I didn't see a way to upload an attachment.  Here's the file contents:

00 FF FF FF FF FF FF 00 04 72 24 05 CB EF 90 64
31 1A 01 04 B5 3C 22 78 3E 0C 95 AB 55 4C A0 24
0D 50 54 BF EF 80 71 4F 81 40 81 80 81 C0 81 00
95 00 B3 00 D1 C0 56 5E 00 A0 A0 A0 29 50 30 20
35 00 56 50 21 00 00 1A 00 00 00 FD 00 38 4C 1F
5A 19 00 0A 20 20 20 20 20 20 00 00 00 FC 00 4B
32 37 32 48 55 4C 0A 20 20 20 20 20 00 00 00 FF
00 54 36 41 41 41 30 30 34 38 35 32 34 0A 01 70
02 03 19 F1 4C 90 05 04 03 02 01 11 12 13 14 1F
20 23 09 07 07 83 01 00 00 02 3A 80 18 71 38 2D
40 58 2C 45 00 56 50 21 00 00 1E 01 1D 80 18 71
1C 16 20 58 2C 25 00 56 50 21 00 00 9E 01 1D 00
72 51 D0 1E 20 6E 28 55 00 56 50 21 00 00 1E 8C
0A D0 8A 20 E0 2D 10 10 3E 96 00 56 50 21 00 00
18 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 F1


You should be fine then


Fine in what way?  I'm still getting HDCP errors.


You pass HDCP test on Cyberlink and I cannot reproduce the issue. What do you want me to investigate? 


Hi fsadough,

First off, I want to thank you for all the help you provided so far.  I first posted about this issue back in October of 2018 and there has been several updates since then indicating a possible fix was available.  But unfortunately this issue is still unresolved.  

I know each system is unique and so troubleshooting issues like this can be difficult.  AMD appears to have partially fixed the HDCP issue, because the error is not appearing in the Cyberlink tool, but other end applications are still showing the HDCP error.  The problem is not isolated to a single program, but all HDCP content I've tried to play.

As described before, my monitor and DisplayPort cables are HDCP compliant, because the exact same setup works with my integrated graphics with no HDCP errors.  One theory of why the issue cannot be repeated on others PCs is because they are using DP 1.3 or greater which is using a newer version of HDCP.  While DP 1.2 (my system) does not support HDCP 2.2 used for 4K content, it is HDCP1.3 compliant, which is sufficient for HD content (as proven by my integrated graphics).

I say all of this because this is a case where the Cyberlink test is not a valid test for HDCP compliance.  Not only is this test a third party test, my setup is an instance where the Cyberlink results are valid only for Cyberlink and not other streaming services that utilize HDCP.

PS - Reading through the following article (High-bandwidth Digital Content Protection - Wikipedia) it appears that HDCP 2.2 and HDCP 1.3 are quite different and the newer version is not backwards compatible.  Could it be possible that Cyberlink is testing for HDCP 2.2 compliance, but since that is not backwards compatible with HDCP 1.3, that is why I'm still having issues?  Also AMD fixed HDCP 2.2 issues, but HDCP 1.3 issues still need to be resolved?

  1. What is the exact make and model of your monitor?
  2. Which driver have you installed?
  3. Send me the screenshot of the error message you are getting
  4. Give me the name of an HD content you are trying to play on Amazon Prime, Netflix or YouTube
  5. Send me an AMDZ report:
    AMDZ Report
    - Please extract the file from this link:
    - Run amdz.exe file as an Administrator
    - Select “Save All“ and “HTM“ as the output format
    - Click on the blue button to save the report
    - The .htm file will be saved in the same folder where you extracted the zipped file

Sorry, I was on the road with work yesterday.  See answers below.

  1. Acer K272HUL
  2. Radeon™ Pro Software for Enterprise Revision Number 19.Q1.2
  3. Amazon - Guardians of the Galaxy Vol 2.PNGVudu - Incredibles 2.PNG
  4. The error appears on all purchased HD content on Vudu and Amazon.  The two screenshots from above are from the movies Guardians of the Galaxy Vol 2 and Incredibles 2.  The content will play in SD, but I get the errors when playing content in HD.
  5. The forum doesn't provide a method for uploading files.  Try this download link 

When you click on "Reply" in the regular Thread, look at the top right most corner and click on "Use Advanced Editor"

 in the "Use Advanced Editor" view, at the bottom left most corner you will see" ATTACH" . Click on that to upload a Maximum file of 50 Mbytes.

But if you need to upload a larger file, I found this free website that you can use and is safe: Simple File Hosting - 

NOTE: The link you gave to download your file was considered to be UNSAFE by Firefox which is why I mentioned the other file sharing link.


Thanks elstaci.  AMDz file is attached.


see my previous message


The W3100 is an older GPU which is too old for HDCP 2.2. More recent cards with HDMI 2.0 and DP 1.4 are capable.

Cyberlink has a HDCP tool to check


WX 3100 supports DP 1.4, so it should support HDCP 2.2, right?  (see section Display Outputs)

The WX 3100 is also based off the Artic Islands chipset which is HDCP compliant.


I pass the HDCP test on CyberLink.Cyberlink.PNG

Adept II

Today I updated to the 19.Q2 drivers and now all content in Vudu and Amazon is streaming HD!  Thanks for everyone's help.