cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Adept I
Adept I

HD5970 crossfire not working

Crossfire is not working anymore for me and I can't figure out what's going on.

In GPU-Z it says "AMD CrossFire: Disabled".

In CCC I see a "Disabled Adapter" (?!) and no mention of crossfire in the game setting. The Catalyst TaskIcon context menu does not show any crossfire option.

So, in a nutshell, to me it seems the second GPU is simply disabled. I'm not aware I did this on purpose. How can I enable it again?

Currently in e.g. FarCry3 I get 30FPS, same in Arma 3. But I know that in both games I can get almost twice as much FPS; I've played FC3 with steady 60 FPS and gorgeous settings.

Specs:

  • WXP 7 Pro 64-bit
  • Intel Core i7-980
  • XFX Radeon HD 5970 Black Edition
  • be quiet Dark Power Pro P8 1200W ATX 2.3

Thanks for any help!

Tags (2)
0 Kudos
13 Replies
Highlighted
Community Manager
Community Manager

Re: HD5970 crossfire not working

What drivers are you using?

0 Kudos
Highlighted
Adept I
Adept I

Re: HD5970 crossfire not working

Hello amdmatt!

Sorry for missing the most obvious part!

There are not much choices anymore due the card/driver being marked as legacy, thus I tested both drivers from Legacy  :

- 15.7.1

- Crimson Edition 16.1.1 Beta

Before installing either driver, I used:

- AMD Clean Uninstall Utility

- Display Driver Uninstaller Download version 15.7.4.1

To make as sure as possible to have a clean system.

thank you!

0 Kudos
Highlighted
Community Manager
Community Manager

Re: HD5970 crossfire not working

We are aware of this issue and we hope to have a fix for it soon, stay tuned.

Highlighted
Adept I
Adept I

Re: HD5970 crossfire not working

For the record, although I think your post is spam-y due this off-topic external link: I've the AMD specific drivers, I don't know what AMZ zero core or ULPS is supposed to be and I'm always testing in fullscreen mode.

0 Kudos
Highlighted
Adept I
Adept I

Re: HD5970 crossfire not working

Just for completeness, a crimson screenshot (german, unfortuantely; don't know how to just switch the interface to english)

greenshot_2016-02-26_20-37-30.png

It's showing one of the GPUs numbered #6 as "deactivated"

greenshot_2016-02-26_20-39-40.png

And here the "primary" one:

greenshot_2016-02-26_20-40-16.png

I'm really crossing my fingers on some information from AMD.

I completely realize the card is old and my system isn't new, but I know for a fact (because I've played them on the very same system) I still can get 60 FPS in my favorite games if both GPUs work. But without it's just ... well :-(

0 Kudos
Highlighted
Adept I
Adept I

Re: HD5970 crossfire not working

I finally got Crossfire working again by going back to the 15.7 drivers. I found them via this answer on Stackoverflow:  windows 7 - New AMD Catalyst driver update screwed things up. Where can I find and older version? - ... which points to all previous drivers: Previous  . Not sure why I was never able to locate that page myself. Anyway.

That's how the information on screen looks now:

greenshot_2016-02-28_01-38-34.pnggreenshot_2016-02-28_01-38-45.pnggreenshot_2016-02-28_01-39-04.pnggreenshot_2016-02-28_01-41-32.png

Some notable differences to my previous screens:

- second adapter does not appear as "decativated" but "linked"

- GPU-Z shows "AMD Crossfire: Enabled (2 GPUs)"

- The task info icon context menu shows three entries and not four and enables access to "AMD CrossFireX Settings" again

0 Kudos
Highlighted
Adept I
Adept I

Re: HD5970 crossfire not working

Just for another test I went to 15.7.1 but Crossfire didn't work. I can confirm that 15.7 is the last one for which Crossfire worked on my system.

This issue was really nagging me, because I did absolutely nothing wrong and lost hours of hours because the provided drivers simply don't work. And that even though I'm definitely not alone, if one cares to search the forum:

0 Kudos
Highlighted
Adept I
Adept I

Re: HD5970 crossfire not working

amdmatt wrote down @ 24.02.2016 11:01 "We are aware of this issue and we hope to have a fix for it soon, stay tuned."

But its still not working,i feel betrayed!

My Thread:
HD 5970 - Crossfire only with CCC 13.12

- Dual-GPU 5970 dont work -

I have tried 2 CPUs, 3 Mainboards & 6 operating systems now.


- AMD Phenom II 965

- Intel I3-6100

- AsRock Fatal1ty Z170 Gaming.-ITX/ac
- AsRock 980DE3/U3S3
- Asus M5A 78L-M USB3

Ubuntu 14 <- WORKS
Ubuntu 16 <- DOESNT WORK


Windows 7 <- WORKS UNTIL 13.12

Windows 8 <- WORKS UNTIL 13.12

Windows 8.1 <- WORKS UNTIL 13.12

Windows 10 <- WORKS UNTIL 13.12

Why AMD disabled our second gpu in the new drivers?! There is no problem on ubuntu 14 and there is no problem in win7-win10 with ccc 13.12. How to work around this problem?! I need the second GPU for my lab rig. -.-

0 Kudos
Highlighted
Esteemed Contributor III

Re: HD5970 crossfire not working

Can I assume all of you have notified AMD of this issue? AMD Issue Reporting Form

0 Kudos