cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

shinkenshi
Journeyman III

GPU Scaling "Preserve aspect ratio" not working in games

GPU: AMD Radeon RX480 4GB

CPU: i7 4770k

GPU Drivers: Radeon Software Version 19.6.2

Operating System & Version: Windows 10 v1803

Description of Original Problem: I just recently upgraded from my 29" ultrawide to a 4k tv. I am trying to play some games in ultrawide resolution on the new 4k tv but man it is almost impossible to get it working.

Troubleshooting: The problem I am having is that "Preserve aspect ratio" only works in the desktop. When I launch a game using an ultrawide resolution, it is stretching the screen as if I picked Full Panel. The only way I have been able to get around this so far is by picking centered (which is working properly) and using 3840/1600 resolution. There are scenarios where I will be unable to drive such a high resolution however and want to dip down to 3440/1440 or 2560/1080.

Some additional troubleshooting I did, just to see if it is specific to the TV. I switched back to the ultrawide monitor and launched a game at 1920x1080 with GPU scaling enabled and preserve aspect ratio. It also stretched the game to full screen, so this appears to be monitor independent.

Has anyone else run into similar issues that has a fix? Only thread I've seen that's actually posted a solution is https://community.amd.com/thread/235771 , and the fix did not help fix my scaling issue.

0 Likes
13 Replies
shinkenshi
Journeyman III

I have an update of sorts. Would really appreciate it if anyone had similar experience can chime in here.
 
Through a lot of trial and error, I found out that that preserve aspect ratio is not broken in all games. Max Payne 3 is especially useful since I can switch the in-game renderer. It turns out that directx 9 fullscreen properly maintains the aspect ratio in fullscreen mode, where as 10, 11, and 12 will stretch to fill the screen for whatever reason unbeknownst to me. Does anyone know of a workaround or configuration change that I can make to maintain proper aspect ratio in all renderers?
 
Thanks

The aspect ratio in some games still does not work, I tried everything, did anyone find a solution to the problem?

Noticed that the video adapter sends the monitor in any mode 1920x1080

Everything is as above

 
0 Likes

 It turns out that directx 9 fullscreen properly maintains the aspect ratio in fullscreen mode, where as 10, 11, and 12 will stretch to fill the screen for whatever reason unbeknownst  -   it really is

LAST DRIVERS, PLS HELP!!!!!!!!

HELP

0 Likes

Just out of curiosity, is GPU Scaling also enabled?  Otherwise the display will be handling the scaling.

0 Likes

Yes off. Since the display needs to be scaled. Even so, the option is unchanged(if enabled)

0 Likes

The GPU scaling options in the driver do nothing if GPU scaling is set to off.  The scaling will then be done by your display and the settings there-in.  You likely have a stretch setting set in your display and it will always do that form of scaling.

 

If you want to manage scaling with the graphics driver, set your display to native and disable any full, stretch, etc options in the display.  Set the display to it's native resolution and refresh rate in windows.  Enable GPU scaling and select the form of scaling that you want.

0 Likes

 
0 Likes

so bad amd so bad......

Any luck here?
It has never worked for me either, shows up fine in windows but in dx11,12 games it doesn't preserve the ratio.
"Centered" works fine, just not preserve the aspect ratio.

0 Likes

You could try doing this.  First set your desired resolution in windows, then start a game you are having issues with.  Change the resolution settings in the game to match what you had set in windows, go CTRL-ALT-DEL return to desktop , go to GPU scaling in Adrenalin , and set on "preserve aspect ratio".  Return to the game.  Did it hold it? 

0 Likes

same exact thing for me. and trying to use freesync, ultrawide monitor, and super res on non-dx9 apps is a nightmare. they all conflict with each other.

was disappointed when i couldnt run super res on tarkov and modern warfare because preserve aspect ratio stretched the game across my monitor and i couldnt unstretch it with monitor scaling bc freesync disables it

0 Likes