cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Highlighted
Adept I
Adept I

Gigabyte RX 5600 XT Gaming issues

So this is my very first post in the forums, basically my RX 5600 XT refuses to work properly, I got the card for the last 3 weeks and basically all the fixes posted on the internet doesn't work. I already sent reports for the drivers on the amd support page. Here are my issues

My games like Kingdom Come Deliverance, Rise of the Tomb Raider, Final Fantasy XV, Resident Evil 2, Resident Evil 3 Demo will play for a variable length of time and will always end up with a TDR Failure, Black Screen, Green Screen or a hard restart. Only Dota 2 seems to work fine.

Adobe Creative Cloud apps like premiere and after effects end up green screening too so not only my gaming has issues but also my work is compromised. 

I reinstalled Windows,

Used DDU as I had an NVIDIA card before this,

Tested driver versions 20.1.3 to 20.3.1 using DDU before installing drivers,

Installing driver only without the software,

removed my pci-e extender,

set the PCI version on my bios to 3.0,

removed my cpu overclock.

disabled hardware acceleration,

updated windows, bios, chipset.

Had a 1070 that worked flawlessly before I got this card.

basically the only thing left that I can do is return the card and swap it out with a 2060, but with the ongoing pandemic I am basically stuck with my $299 paperweight. Is there any fixes that I may have missed out?

Specs:

Windows 10 Pro 1909

Ryzen 5 2600

Asus B450-F ROG STRIX

Corsair 16GB Vengeance 3200

Gigabyte 5600 XT Gaming

Seasonic m12 700w

Samsung 250gb 850 evo 

I attached crash reports from some of the games below if that helps.

Tags (1)
44 Replies
Highlighted
Adept I
Adept I

Re: Gigabyte RX 5600 XT Gaming issues

Finally seemed to fix mine. I don't have any crashes for about 2 days since I set the power limit of the card to 30% on afterburner. No negligible performance loss either and I was able to oc my 5600xt to the max 1820mhz and 1860mhz for memory. I don't think my psu is causing any issues because it's fairly new, it's a seasonic m12 700w unit and it's 2 years old. I hope this can help. I virtually did every suggestion on the forums, even tried a fresh install, but this one might have permanently fixed it. I'll update in a week if a crash occurs. Tell me if it works!

0 Kudos
Highlighted
Adept III
Adept III

Re: Gigabyte RX 5600 XT Gaming issues

Same issue here! Are you running it under FA0 bios version? I needed to downgrade it the F2 as I've been out of crashes/reboots so far. Sad that we need to figure out a workaround to put it to work properly :/

Any update?

0 Kudos
Highlighted
Adept I
Adept I

Re: Gigabyte RX 5600 XT Gaming issues

Got a brand new Gigabyte RX 5600 XT GAMING OC rev1.0 last week. It's simply not working. Crashes and freezes like mad on adrenaline 2020 20.2.2 as well as on adrenaline 2020 20.4.1. 

Setting a lower power target seemed to work for a day, then again started to crash and freez. Also tried to lower gpu and mem clocks in MSI Afterburner, still nothing. Tried DP and HDMI with and without Freesync. Both on FA0 and F2 bioses. Now I'm switching back to my old GTX 1060 . It's too late to return 5600 XT. I've bought it on Newegg, but live in Europe, and 30 days expires on 15th. Only the f@#ing LED works as intended on this card. I am very very upsed and mad. 

My specs:

CPU Ryzen 5 2600 + Noctua NH-L12S cooler

MB ASRock Fatal1ty B450 Gaming-ITX/ac

16 GB (2*8) Crucial Ballistix Sport LT 3200 MHz DDR4 DRAM

500 GB Samsung 970 EVO Plus M.2 NVMe SSD 

EVGA SuperNOVA 650 GM, 80 Plus Gold 650W PSU

GIGABYTE Radeon RX 5600 XT GAMING OC 6GB

EVGA GeForce GTX 1060 SC GAMING 3GB DDR5

0 Kudos
Highlighted
Adept III
Adept III

Re: Gigabyte RX 5600 XT Gaming issues

Sup man! 

Have you tried to:

1) Unistall chipset drivers using the AMD Cleanup tool?

2) Unistall the previous drivers using DDU?

3) Get your Windows 10 version 1909 fully updated?

4) Turn all the features in Adrenalin off?

Here, I was having lots of issues trying to run it under FA0 bios. It just crashed many many times.. unsuable!

When I downgraded to F2 and wiped all the old traces of old drivers it turned out to get stable.. no more crashes so far. 

An advice here.. since you were using a nvidia card before this, try to have a fresh windows install. I've read a lot of people who are having problems switching brands without formating.

Keep us updated! Good luck!

Highlighted
Adept I
Adept I

Re: Gigabyte RX 5600 XT Gaming issues

Actually updating windows to 1909 seemed to help.

On FA0 bios the system still crashes after 15-20 minutes in GPU-Z 2.3.0 PCI-Express Render Test (green screen, something new). Went back to F2 bios and yesterday no issues at all, 40 minutes on GPU-Z render test, except Modern Warfare Warzone, but not a total system freez, only the game crashed. I keep Adrenaline features off for now, as I am very tired of rebooting my PC. 

Note, when going from FA0 to F2 bios - memory clock and gpu clock remains from FA0. You have to default memory clock via Aorus Engine from 14000 MHz to 12000 MHz and set gpu clock in MSI Afterburner from 1780 to 1620 MHZ.  

xirombinha Yes, I've used DDU for gpu and chipset with AMD removal tool previously. For now, I think, there is no need for a fresh windows install. Anyway, thank you for help. 

Highlighted
Adept III
Adept III

Re: Gigabyte RX 5600 XT Gaming issues

That's nice you've found out a way to put it to work properly. About "when going from FA0 to F2 bios - memory clock and gpu clock remains from FA0".. Are you sure?

I think their clocks are completely different. Where did you get that info?

I screenshot Gpu-z specs on both versions.. I got this:

comparativo.jpg

the left one is on FA0, the right one is on F2.

Highlighted
Adept I
Adept I

Re: Gigabyte RX 5600 XT Gaming issues

Hi, 

I`m on F2 bios. Although GPUZ shows new values, when testing sensors shows that gpu clock hasn't changed since FA0. So I have set it manually in Afterburner and underclock the gpu. Same with memory, only memory I have to do it once, but gpu every time I boot the PC.

1.gif2.gif   

0 Kudos
Highlighted
Adept III
Adept III

Re: Gigabyte RX 5600 XT Gaming issues

That's weirdo. I set everything standard and auto in adrenalin. I don't need to change anything when windows starts. I dind't manged to underclock. Have you ever tested without undervolting?

0 Kudos
Highlighted
Adept I
Adept I

Re: Gigabyte RX 5600 XT Gaming issues

Since I got 2 crashes on FA0 and switched to F2, I set it every time the GPU to 1620 MHz, coz I am very tired and annoyed of crashes and I don't want to risk anymore. In Adrenaline I switched off everything and won't touch anything for a while. I think Gigabyte has to work with AMD on improving stability of this card.