Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Game problems

I have been having problems launching CSGO after upgrading my GPU to a new one.

I had ASUS GeForce GTX 1060 6GB Dual OC BLACK and changed to Asus Radeon RX 5700 XT ROG Strix OC

The problem:

When I launch the game, nothing happens. No screen pops up and no errors. Steam only states that the game is “running”.
The game does not show up in task manager as running in the beginning but after trying to force steam to exit then it shows up so I can end task.


So when I installed my new GPU I did not know that I had to uninstall my old drivers from GeForce and then install the new once from AMD. I installed the AMD once while having GeForce also installed.


Here is what I have tried to solve this:

- Uninstalling all drivers (including AMD and GeForce) with the help of DDU program (in safe mode) and then reinstalling only AMD driver from their website via Radeon Software (Did not use auto detect)

- I have tried reinstalling CSGO fully

- Setting Launch options to -nod3d9ex and -nod3d9ex1, and also -Safe

- Checked DxDiag to see if anything is out of order but it seems to be doing just fine
One thing though: Inside dxdiag under System – System information, It shows that System Manufacturer is n/a, Same thing with System model, Bios and processor. / I don’t know what it means but I thought maybe good to mention.

- Inside csgo local files – Tried changing Compatibility options to Run with Windows 8 and as an Administrator.

- Inside Radeon Software I have turned off all graphics settings (Incl Anti-Lag)

- Tried verifying game files through steam

- Inside compatibility settings, I also tried running the game with 640 x 480 screen resolution, it actually changed my whole monitor resolution, as if it was running..

Here is my rig:

Screen 1; (Use for gaming) MSI optix MAG241CR 144HZ with Freesync 24"
Screen 2; ASUS VG245 24" 60 HZ

Motherboard: Asus Rog Strix Z390-F s-1151
Ram: HyperX 16GB (2x8GB) DDR4 2666MHz CL16 Fury
CPU: Intel Core i7 9700K 3.6 GHz 12MB
GPU: AMD Radeon RX 5700 XT
Power Supply: Corsair CX650M 650W PSU

Keyboard: Corsair K65 RapidFire
Headphones: HyperX Cloud Flight Wireless
Mouse: Logitech G402

I appreciate any help, thanks!

2 Replies
Journeyman III

Re: Game problems

I solved this.

If anyone else has the same problem try following: Inside Task Manager end task called: Nahimic Services, Anything with nahimic.. Thank god!

Adept I

Re: Game problems

Did you try disable the Radeon Enhanced Sync? I got a similar problem, after few sec in a game the whole game was freezing until i go to windows and get back in game all in 10-15 sec. After i disable this all the game start work like before.