cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Neromeo
Adept I

G.Refresh Rate

hi ALL, why do i no longer increase G.Refresh Rate (Hz) to 58 as I used to reinstall windows 10 on an external monitor, but only allow up to 30hz?

0 Likes
7 Replies

The AMD Support link of FAQ mentions how to properly configure G.Refresh Rate: https://www.amd.com/en/support/kb/faq/dh-032

If you still are not getting ~60Hz from your Monitor make sure your Monitor and Windows Settings -Display are set to the correct Resolution and Frequency. Also check Windows Settings - Graphics

If everything is configured correctly then you need to post more information about your computer setup as per AMD Rules. especially how the Monitor is connected to the GPU card and Make & Model of the GPU and Monitor and if you are using an Adapter (DP>DVI or HDMI>VGA etc) to connect your monitor.

I tried all the methods you specified, with the first methods I used to be able to increase the frequency to 60 Hz, but after reinstalling windows, this methods no longer increase to 60 Hz, automatically only 30 Hz is specified.

My computer laptop is here https://consumer.huawei.com/en/laptops/matebook-d-14-amd/
I use HDMI to HDMI.
The monitor is here https://www.philips.co.uk/c-p/345B1C_00/curved-ultrawide-lcd-display

0 Likes

It is possible the problem is with your HDMI cable or your laptop's HDMI Output version.

Your Phillips Display uses HDMI 2.0 input:

Screenshot 2021-01-29 112623.png

Your Laptop HDMI Port doesn't indicate which version of HDMI output it has. If your Laptop HDMI output is 1.4 you won't be able to get 4k@60hz since HDMI 1.4 as per this Cable tech site:  https://glenwing.github.io/adapters/?output=HDMI

Screenshot 2021-01-29 132634.png

You need a HDMI-HDMI 2.0 Cable to run 4K@60hz:

"Do HDMI 2.0 cables work with regular HDMI ports?

You can use your existing HDMI cables with new HDMI 2.0 connections as the connectors themselves haven't changed. While there's no such thing as an HDMI 2.0 cable per se, displaying 4K at 50/60Hz will require a High Speed/Category 2 HDMI cable.Sep 13, 2013"
 
As an example, this 4K HDMI-HDMI Cable support 4k@30hz maximum: https://www.amazon.com/AmazonBasics-High-Speed-HDMI-Cable-1-Pack/dp/B014I8SSD0
Screenshot 2021-01-29 131858.png
 
Screenshot 2021-01-29 132201.png
 
If you set your Phillips to run at 2k or  3.5K (3440x1440) you should be able to get 60hz.
0 Likes

thanks, you still didn't understand me, before reinstalling windows everything worked in 60 hz mode, now it only gives 30 hz ... there is no problem with the cable because i have an HDMI 2.1 cable too, but it doesn't affect either

0 Likes

Sorry I misread your post.

If it was working before you reinstalled Windows and not after then is sounds like some Windows Setting has changed or Windows Update that was added during installation or a setting in Radeon Settings.

Try resetting your Radeon Settings to Factory Reset and see if it starts working.Then try various Radeon Display settings and see if 60 Hz start to work.

Also check Windows Settings - Graphics and see if you can select 60 Hz frequency by trying various Resolutions.

Screenshot 2021-01-30 171653.png

My thinking is first trying to get 60 Hz to work with any Resolution and then go from there.

Make sure your Monitor settings is set correctly to receive the correct Resolution and Frequency.  Check all the HDMI settings on the monitor.

Generally when you get maximum 30 hz sounds like the cable is not able to transmit 60 hz or GPU card or Monitor issue besides being a misconfigured setting.

0 Likes

very thanks, I tried everything I could and advised, no one helps

0 Likes

Or maybe it's related to AMD FreeSync, currently writing to me that it's not supported?