cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

trai12
Journeyman III

freesync problem

Jump to solution

Hello, i have a problem with freesync on games. I have a RX 580 8gb and AOC C24G1 monitor (144hz). I have enabled freesync on monitor OSD and Radeon Settings, set the 144hz on windows and have the DP cable connected aswell.

My problem is after i enable Freesync on Witcher 3 on radeon settings game profile i get microstutters and some flickering and doesn't feel smooth. When i turn off freesync on radeon settings game profile everything works smoothly without problems. Another thing i tried and works: freesync is enabled on game profile, i change to borderless window instead of fullscreen (in-game), everything smooth again. I get 80-110 fps if it's worth to mention and monitor freesync range is 48-144hz.

I tried DDU clean install drivers, at first it worked without problem and i thought i solved the problem but after i restarted pc the problem came back. The only solutions i found are these: Have Freesync enabled in Radeon game profile and play the game in borderless window (although FS works better in fullscreen?) and the other one is to turn off Freesync in Radeon game profile only and play the game normal in fullscreen. Do those mean freesync is not working properly?

0 Likes
1 Solution

Accepted Solutions
alseu
Challenger

Re: freesync problem

Jump to solution

I've never used that particular monitor but these are the things i'd try first:
1) Install monitor drivers for c24g1 from AOC official website. If you installed it someday then make sure the driver is on. Windows update likes to switch the driver back to the Generic PNP, default DDU profile also delete's all monitor drivers. So make sure you have the right one.
2) Only enable freesync in radeon settings Display section and not within specific game profiles.
3) During your gameplay (fullscreen or borderless) open monitor OSD settings > Extras > check what the V. Frequency value is. On some monitors you can see this number dynamically changing in OSD (as it should in reality with adaptive sync enabled) but on some don't, anyway it can help to understand if freesync still working while you run Witcher 3 bordeless.

View solution in original post

2 Replies
alseu
Challenger

Re: freesync problem

Jump to solution

I've never used that particular monitor but these are the things i'd try first:
1) Install monitor drivers for c24g1 from AOC official website. If you installed it someday then make sure the driver is on. Windows update likes to switch the driver back to the Generic PNP, default DDU profile also delete's all monitor drivers. So make sure you have the right one.
2) Only enable freesync in radeon settings Display section and not within specific game profiles.
3) During your gameplay (fullscreen or borderless) open monitor OSD settings > Extras > check what the V. Frequency value is. On some monitors you can see this number dynamically changing in OSD (as it should in reality with adaptive sync enabled) but on some don't, anyway it can help to understand if freesync still working while you run Witcher 3 bordeless.

trai12
Journeyman III

Re: freesync problem

Jump to solution

Dude it was so simple and your answer solved my problem! It was the driver the .inf one, after i installed it (with right click, install) the problem was solved. Thank you so much!

0 Likes