Showing results for 
Search instead for 
Did you mean: 


Adept I

FPS limited to 30 ?

hello , i am using RX 480 i have noticed my games are caped to 30 FPS . unfortunately i did not know what to do in the AMD  Radeon settings, kindly requesting help and thank you very much

6 Replies

Most likely a global setting got changed. It could be a chill setting or Vsync setting maybe. You could re-install the driver with the factory reset option and that should fix it. Or try to figure out what setting in Radeon Settings you changed. 

Known issues list has

Modifying the HDMI Scaling slider may cause FPS to become locked to 30.

You should follow pokester‌ suggestion to reinstall with factory reset.

thank you very much for your reply , i have factory reset the settings however i am still seeing the games are locked to 30 FPS even though in game settings v-sync options and such as are disabled

Adept I

the problem has been solved, the issue wasnt from the video card nor the AMD settings, it was an option in the samsung TV , where you have to select the HDMI input type to either Game or PC , whatever you prefer and everything will be fine


That's a quick fix, maybe.. solved, I don't think so.  


Game mode utterly destroys display quality.  The option was intended for input lag, not AMD driver bugs. 


Edit:  Game Mode degrades quality so much that I wasn't even going to test it out on my Samsung TV.. but I just did.  Still locked at 30fps and looks like **bleep**.  Are you sure you weren't just fooled by the input lag? 

Journeyman III

Hey all, glad op got his issue solved,


for anybody in the future that is having problems with the fps locking while using hdmi scaling in amd radeon settings, turn GPU SCALING OFF, and you will need to go into the service menu of your hdtv its hidden you will need to enter a code to access it depending on your HDTV/Monitor MODEL and find the OVERSCAN OPTION ( in my case it was a 50 inch RCA HDTV 4k, I kept getting locked in low fps when using hdmi scaling because it would overscan at 1080p) eventually i found the overscan option in the service menu on the hdtv and Successfully corrected it, now im running my rx 580 @ 1080p/60 with no under/overscan issues.