cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

thejonamr
Journeyman III

External monitor suddenly stuck at 640 x 480 in only one specific PC:Monitor pairing

My setup is approxiamtely 10 years old, and I have only swapped out the GPU since, except for the HDDs and SSDs. Monitors have come and gone as well, but you will find that I do have some old monitors.

I have a 4-screen setup and it is as follows:

- Packard Bell 220DX bd (DP - DVI)

- ASUS PB278Q (DP - DP)

- LG W2443T-PF (DP - HDMI - DVI) [This is the screen I have a problem with]

-Samsung QE65Q8FNA (HDMI - HDMI)

 

In general my system setup is:

Processor: i7-3770K

RAM: 16 GB DDR3

OS: Windows 10 Pro 64 bit (19043.1110)

GPU: AMD Radeon RX Vega 56

PSU: SP-S750 750 Watts

MB: ASUS P8Z77-V DELUXE

Software: AMD Radeaon Software version 21.6.1

 

Now on to the problem. I was going to hook up my raspberry pi 4 to the LG monitor, and therefore disconnected my pc from the LG. Before this I have used this setup for almost a year now without any issues what so ever, 1920 x 1080 resolution on all monitors, except the ASUS which i run at 2560 x 1440.

Then I could not find my HDMI - micro HDMI cable, and chose to connect the PC to the LG again. Note, this is not the first time I have disconnected this screen from my pc over the last year. I have used it together with my laptop, and other PCs several times. After conneting it to my pc it came up with a resolution of 640 x 480.

 

In the Windows 10 display settings all settings under Scale and layout except orientation are greyed out.

In device manager the LG comes up as a Generic Non-PnP Monitor, same in Speccy. While the other screens are still functioning just fine.

I have tried uninstalling all monitor drivers in device manager, even the hidden ones. And then installed some of them using the "scan for hardware changes" button in device manager.

I also tried what one forum suggested and tried to update the driver of the Non-PnP monitor as follows:

Right click -> Update driver -> Browse My computer for drivers -> Let me pick from a list of available drivers on my computer -> unhook the show compatible hardware -> select (standard monitor types) in left pane -> select Digital Flat panel (1920 x 1080 60HZ) in the right pane. No change.

Then just for fun I tride doing the same thing, but instead i chose the Generic PnP Monitor option in the right pane, yet again, no change.

I updated AMD Radeaon Software version 21.6.1 to 21.6.2, no change.

I used DDU (latest version, downloaded today) and removed the AMD drivers. I went into safe mode before running the program. Just as a precausion I even ran it two more times, selecting intel, and nvidia the two other times instead of amd. Still no change, still stuck at 640 x 480. I installed AMD Radeaon Software version 21.6.1 once again. Still at 640 x 480.

Then I tried connecting the LG to my laptop using a different cable, here we go, 1920 x 1080 awesome. Connecting it to the pc again, 640 x 480. Once again, connected the screen to my laptop, but this time using the same HDMI cable that i used on my pc, again 1920 x 1080, great.

Then i figured that the DP to HDMI adapter might be broken, disconnected my Samsung TV from the GPU and connected the LG to the HDMi port. 640 x 480. Then I connected the TV to the GPU via the DP to HDMI adapter that i used with the LG before. 1920 x 1080. The LG still runs at 640 x 480.

I have tried turning off and on my PC. I have tried taking all power from both the pc and the LG by unplugging the power cables for over an hour. No luck. I have tried conencting the DP to HDMI adapter to other DP ports, and still get the same behaviour for the LG screen. Then i swapped out the DP to HDMI adapter with a DP to DVI adapter, and of course a DVI cable instead of the HDMI cable. Still at 640 x 480.

I have also factory reset the LG monitor, which also did not change anything. I have also tried downloading the windows 7 drivers for the LG monitor as it were the only one available, and went into device manager and tried updating to that one by browsing for the unpacked driver. No luck.

Then I figured that I might as well factory reset my pc. Reinstalled Windows 10, deleted all personal files. Still at 640 x 480. Installed AMD Radeon Software version 21.6.1 640 x 480.

And now I have almost given up, and figured that my last option was to try the forum.

 

 

0 Likes