cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Jeaa42
Journeyman III

Error "AMD no graphics driver is installed..." Radeon R6 on Asus X555D

Hello, I've been having problems for a couple of weeks ago.

I had been getting a notice about my drivers not being correctly installed or updated, even tho my pc was working just fine and running games. When I decided to update them by using the Combined Chipset and Radeon Graphics driver installer available at https://www.amd.com/en/support the drivers decided to suddenly stop working. On device manager I get an error code 43. Already tried un-installing and re-installing, it never let me go back to the previous version, tried this: https://www.youtube.com/watch?v=bFVNo-6Vt6E (it's in spanish tho), and tried seeing if there was a specific windows update that made compatibility non-existent, but couldn't find anything. Saw a couple of threads with similar problems, but their solutions were kinda outdated (answers were of at least 2+ years). 

If anyone could help me finding how to re-install a compatible set of drivers or just solve this I would really appreciate it. 

 

My laptops specs are:

Model: Asus x555d

Processor: AMD A10-8700P  1.8 Ghz, 10 Compute Cores 4C + 6G   1.80 GHz

RAM: 8 GB

Windows 10 Pro, version 1909, fully updated, 64-bit

 

If Im missing any important info please let me know. Thanks in advance. :)

0 Likes