Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Elden Ring performs worse on 7900 XTX than 6900 XT

update 2: my post has been marked as spam, so likely nobody is reading this. But anywho, I believe the problem is that the GPU was no fully seated, because the PCIE slot lock never fully engaged, because the card is slightly too long and cannot get flush as possible to the motherboard on the far end (it touches the hard drive rails in the front). Also, while I grumbled, I did put the 6900 XT back, which sat flush against the slot and engaged the plastic lock, and in the OS it was properly reporting as PCIE 3 x 16, and badabing, ran Elden Ring as smooth as glass. I guess Elden Ring really taxes dem bandwidths, yo! I will get a new case/chassis and only report back if that doesn't work. Cheers, mods, for marking me as spam!

update 1: just tried 22.12.2 drivers for 7900 series and the problem persists.

Operating System: Windows 11 Pro 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: X470 AORUS GAMING 7 WIFI
BIOS: F63c (type: UEFI)
Processor: AMD Ryzen 9 5950X 16-Core Processor (32 CPUs), ~3.4GHz
Memory: 32768MB RAM
Available OS Memory: 32688MB RAM
Page File: 13346MB used, 21390MB available
DirectX Version: DirectX 12
DirectX Database Version: 1.4.3
DxDiag Version: 10.00.22621.0001 64bit Unicode

GPU current 7900 XTX/previous 6900 XT
PSU CORSAIR - RMx Series 850W ATX12V 2.4/EPS12V 2.92 80 Plus Gold Modular Model: CP-9020180-NA

m.2 slot 1, Samsung SSD 970 EVO 500GB (S466NB0K600735X) boot drive
m.2 slot 2, WD_Black SN750 1TB WDS100T3X0C-00SJG0 (190252420965) steam library

Before upgrading to 7900 XTX, all games ran swimmingly at max 4k settings with the 6900 XT, with all drivers including 22.12.2.
Popped in 7900 XTX. God of War, Dark Souls III, Sekiro, ran better than swimmingly, but Elden Ring ran like mud. Frametimes at ~25ms. All other games have ~8-16 ms. Elden Ring FPS dropped from a steady 60FPS to ~30-45, particularly in large open areas. Changing resolution to 1080p doesn't improve FPS. Only thing that brought it back to 60FPS was reducing quality settings to Low across the board.

Updated BIOS. In BIOS, tried setting to pciex16 to AUTO and Gen3. Upgraded Windows 10 to 11. Of course, had to use 22.12.1 drivers, after using AMD Cleanup Utility in safe mode. Swiched on/off smart access memory, freesync, HDR, Radeon Super Resolution. Reseated GPU. Power supplied by two rails. The GPU reaches ~2600ghz with a ~350watt power draw. All to no avail.

One wierd thing, all utilities report that the gpu bus interface is pcie 4 x 16, but is currently set to pcie 3 x 1. GPU under load does not change the reading.

Elden Ring actually gave me an error that said "Frame rate unsuitable for online play" and disconnected me.

0 Replies