cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

salhelder
Journeyman III

DVI not working on RX480

Hardware:

Graphic card: AMD RX480 (8GB)

Desktop

Windows 7 64 bit

Monitor ASUS VG248QE connecting through dual link DVI

Motherboard: ASUS H170-PRO

CPU: Intel i5 6400

PSU is a 650 of a "local" brand

RAM: 16 GB

Here's the issue:

I got an ASUS RX480, one of those that has a DVI-D port, but it only displays during boot before windows loads the drivers. I've installed both the manufacturer provided drivers and the AMD latest drivers 16.11.2, having the same problem on both. I've tried switching the PCI-e slot, also didn't solve the problem.

Also before installing any official drivers it also displays using whatever the generic driver windows installs, but otherwise it just refuses to display anything through this port. I've already updated the BIOS.

HDMI works fine.

Tags (2)
0 Likes
2 Replies
liakojohn
Journeyman III

Re: DVI not working on RX480

Hello my friend! I know this question was filed some months ago, but since I think I've found the answer I will still reply it because many other people could have a similar problem.

Well, just like you, I wanted to connect a (secondary) monitor via DVI and my system would just not recognise it! Before windows loaded it would perfectly display the MSI BIOS loading screen and it would also work in safe mode (Windows 10 standard display drivers). At first I thought it could be a dead/faulty DVI port on my GPU, but after trying (like I stated earlier) using it in safe mode, I was sure the port was just fine! After that I thought it would be a driver issue and I reported my problem to AMD several times. I was desperate because I had just spent 300 € on this card (RX480 Sapphire Nitro+ OC) and I was thinking I had made a mistake upgrading because the secondary screen was working just fine with my old GPU (R9 270X Sapphire). Then, I bought a new monitor which was connected via Display Port and it worked just fine. I used my main (HMDI connencted) as secondary and I could finally work on my projects much easier. About 2 months after buying the new monitor, I found a very old 4:3 HP monitor (HP 1755) and thought I should give one more shot to my DVI port. Guess what! It worked! So, it was my old secondary screen that had the problem. But what was it?

Well, I am not a cable/signal expert, but I think the issue is related to RX480 only delivering Digital and not Analog signal. This is why some RX480 models don't even have a DVI port! Both Sapphire (mine) and ASUS (yours) have a DVI-D port, which as far as I know, delivers a digital signal. So the problem should be that your monitor cannot support Digital signal. The HP monitor I tested might be old but was really good when it first came our, so I guess it could support both Digital and Analog signal.

ASUS is a very trusted manufacturer as far as it comes to GPUs and your card should be just fine! I was between the ASUS and Sapphire model (because ASUS can deliver up to 8K while Sapphire can only deliver up to 4K) but I chose the Sapphire model because I have been VERY SATISFIED by what I've got all these years. Still, do not blame your GPU, blame your monitor. Ask for a friend for a DVI monitor and try it. If it works, then that's it! My DVI monitor was from a "local" (shipped from China) brand and was kinda crap. You simply cannot compare it to a HP monitor, despite it being MANY years old!

I really hope I helped! I need to state that I am not sure about what I said about the Digital and Analog signal, as I am not an expert.

0 Likes
Knorcz
Journeyman III

Re: DVI not working on RX480

The real issue seem to be in dual link cable. Had exactly same issue, it works in safe mode, but not regular. The cable itself isn't faulty as it works with Intel integrated graphics, but not an Amd card.

0 Likes