cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Adept III
Adept III

Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

This a fresh Win7 x64 install with all the latest updates, i tried the new 17.6.1 drivers but it does not seem to install the driver nor the Settings. Installation completes very fast and is not even asking for a reboot. I tried downloading the file which is 456MB 4 times in a row and the result is the same. I even tried with previous 17.5.2 and is seems to be working perfectly, but 17.6.1 simply is not.

Fresh Win7 x64 with all updates.

8GB RX-480M8BFA6 (With Stock 1288MHz)

Intel Core i5 6500
8GB DDR4 2133MHZ

Asus H110M-A

Speler Full HDTV 21" through HDMI1

While selecting Custom Install the only available option is HDMI Audio Device. I believe that the Package itself might have some sort of issue.

Edit 1

Installing 17.5.2 then forcing the W76A_Inf through device manager sort of works, but it is not ideal... there is definitely something wrong in the current package file for Win7 x64 version.

Edit 2

I tried 17.6.1 on a old PhenomII PC with also "Win7 x64 and the result is the same. What the heck is wrong with this new driver? why can't i install them on two different PC's?

Edit 3

I am just going to stick to 17.5.2 for a month or two, this new Driver Package is not working in any of my systems no matter what i do, i will also attach a DxDiag and MSinfo just in case any Engineer or Developer want to take a look.

0 Kudos
1 Solution

Accepted Solutions
Adept I
Adept I

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

Seems it was a package issue, I just downloaded the driver package again and now it's showing all components and installing properly.

View solution in original post

21 Replies
Adept III
Adept III

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

Anyone else who got win7 tried 17.6.1 that can confirm this driver works with any modern Radeon GPU? i just can't install these drivers, even tried on two different PC's while the main was has a fresh window install from a previous day before this driver got released.

0 Kudos
Esteemed Contributor III

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

I have Win7 and R9 graphics...I ran into the same issue when I first tried to install the new drivers. Did a 'clean' install using DDU and all went well.

Delete all AMD software using the computer 'uninstall a program' feature. Reboot in to safe mode...run DDU and choose to let it re-boot. Install the latest driver for your card.

0 Kudos
Adept III
Adept III

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

I already tried this 3 times in a row, Remove files through Add Remove Programs and Features in ControlPanel, then i made a DDU AMD removal in Safe Mode, this are the same steps i take every single new AMD Driver update. But i guess i can try it out again just to be sure.

0 Kudos
Adept III
Adept III

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

Ok, went to Control Panel, Add Remove Programs & Features, Removed AMD Software, then went to Safe Mode and run DDU and removed AMD leftovers, Rebooted, run the 17.6.1 installer and Still not working... this is what i get if i click custom install:

CustomInstall.jpg

If i do Express install the install "finishes" in around 20 seconds, then i get this screen:

Finished.jpg

There is no reboot option or nothing, the only thing i can do is Click on that X in the Upper Left and this is what i get after i reboot Manually:
AfterReboot.jpg

Standard VGA Graphics Adapter and no AMD Radeon Settings when clicking Right Mouse on the desktop, nothing... Driver is borked, i tested my RX480 on a second PC and i get the same result. If i go back to 17.5.2 everything works like a charm.

0 Kudos

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

I didn't have any problem installing it like the other poster is having but even after using DDU and everything the artifacts on screen and crashing still persists.

0 Kudos
Adept II
Adept II

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

Win10x64

MSI970 gaming

MSI RX480 8gb Gaming

AMD FX8370

I got the update available notice through RadeonCrimson to move from 17,5.2 up to 17.6.1. fine, I got the option to clean install which i checked yes to.  That was  it.  nothing but black screen. couldnt boot back into windows 10. tried a dozen times. finally I was forced to sys restore back to 17,5,2 and hoping this will work out. I just rebooted 2x since the sys restore point i made just prior to the update  , currently i am unable to get the software to open.  it is stuck. i have the tray icon but it is dead. can not open the software any way, not rt click adm,not from the start menu.

oh well. will be a long time till i try to update the software sight unseen.  I forgot, when I booted up today from a fully functioning system and well functioning crimson too, i got my first wattman reset to default error msg  with the hex net shaking screen overlay for a second on boot. today. i never even used wattman in the month or 2 ive had crimson 17xx never turned it on , never accepted any of it after the older initial issues i had with it and MSI.

just my 2¢, no clue what is in store with this thing next.  i rue the day when i opted for this RX480 over the comp nVidia one. never used anything but AMD to date. but never again i fear.

0 Kudos
Adept III
Adept III

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

I had so much issues with this RX480... first it was some Random Black Screen that would Lock the PC requiring a hard reset, luckily it was aknowledge and fixed very soon by AMD, then it was the Cursor Mouse Corruption issue that took like 5 different Drivers to be fixed, then it was Doom refusing to work with Vulkan, then it turned out i was installing drivers over older, this is when i started using Add Remove Programs Features to first remove AMD Software from the list, then Safe Mode and then DDU, after i learned the hard way not to ever install new drivers over older and do the formentioned steps instead and then installing new drivers... then i had an issue with Relive just stopped working and no matter what i did it would not appear in the Radeon Settings, it was gone... even going back to older drivers did not fixed the issue so i decided to just do a Fresh Windows Install just a couple days ago,  but now this! even on a whole new freshly windows 7 install!

This is my second Radeon since the first was a PowerColor HD5770 PCS++ but the weird thing is that i never had a single issue with it, nothing nada! and the RX480 has been nothing but trouble... i want to support AMD since i am sick and tired of nVidia BS Anti consumer tactics... but all of all these issues are unacceptable to be honest.

0 Kudos
Adept II
Adept II

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

you are right, of course.  nVidia is no bargain. i have always liked and used AMD everything . i began to build microsoft things in 2008 after 12yrs with MACs only.  I only used AMD because they gave a good deal and preformed well, well enough for me and everyone i knew. I only gripe about this kind of silly stuff. I have no clue whether it is AMD or Win10 or a combo. just too hard for a simpleton like me to fathom.  i just know the black screens and crazy mouse behavior or inability to update something AMD suggested knowing my system. I was happy enough where i was but get the nag screens to update.and when i do get stuck with  no support. I have 3 other computers so not hard to get another one on line. but i made 2 of them Linux Mint in 2016. amd is less friendly , still, with linux it seems. I have a 7950 3gb and a 5870 working but nothing amd in linux for them  for whatever that is worth. I only fear that AMD is not supporting older graphics or processors for that matter. all is headed to ryzen and upward and the 4xx series seems to be tossed under the bus. paid same as the 5xx that came out the same month i got my 480 but less support than the 580 even. so , that is why i gripe.

0 Kudos
Journeyman III
Journeyman III

Re: Crimson 17.6.1 Installation not working on RX480 Win7 x64

Jump to solution

my R9 380 G1 WIN 7 64BIT  NOT WORKING CRIMSON 17.6.1. SOMETHING WRONG

0 Kudos