cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

mischaw
Adept I

Constant micro stuttering on RX 480 w 3700X during games

Constant micro stuttering on RX 480 w 3700X during various games

Examples of the issue

Heroes of the Storm: https://streamable.com/zwg70
Overwatch: https://streamable.com/4b02y

Steps to reproduce

This happens while playing different games, I've tried Heroes of the Storm, Overwatch and Star Wars Battlefront II. It's most apparent at 2560 x 1440 @ 144 hz, but still happens at 1080p 60 hz.

Behavior

Games run micro stutter / lag a lot. Sometimes movement input is ignored in (for example I try to move forward in Overwatch and I'll go another random way with lots of stuttering). In Battlefront 2 I had actual connection lag, but my connection is fine). Battlefront 2 sometimes totally freezes my PC after about 30 minutes of play time.

What I've tried

Different video drivers. Windows 10 reinstall. Taking out the GPU and reinstalling it with different power connector. Taking out 1 piece of 16 GB RAM. +50% power to GPU. Deleting shader cache. Clean booting. I've also ran userbenchmark, all is well except for the GPU which is performing 'way below expected'. The GPU worked fine on a previous lower spec configuration.

Thanks for reading. Hope someone can help :-]

Configuration

Motherboard: Gigabyte X570 AORUS ELITE
CPU: AMD Ryzen 7 3700X
RAM: 32 GB - Ballistix DDR4 Sport LT 2x16GB 3200
GPU: MSI RX 480 4G
Driver: Latest drivers and tried some previous ones.
VBIOS: 113-V34111-F1.
OS: Windows 10 1909 x64
Monitor: Asus mg279q @ 144 hz
PSU: Seasonic Gold 550W
Drive: M2 Samsung 970 1TB

0 Likes
6 Replies
instant_win
Adept III

Re: Constant micro stuttering on RX 480 w 3700X during games

did you install DX libs - dxwebsetup.exe and amd chipset drivers?

0 Likes
mischaw
Adept I

Re: Constant micro stuttering on RX 480 w 3700X during games

Thanks for your comment. Directx comes preinstalled with Windows 10, so why would I have to install dxwebsetup? And I did install AMD chipset drivers.

0 Likes
instant_win
Adept III

Re: Constant micro stuttering on RX 480 w 3700X during games

no, not all dx libs are included, its a long story, you just need it, google dxwebsetup on microsoft site and run it to be sure

0 Likes
mischaw
Adept I

Re: Constant micro stuttering on RX 480 w 3700X during games

Ah okay thanks, I installed it, but no difference.

I did something else though, I set the powerlimit in Radeon Wattman to -50% and the issues in Heroes of the Storm and Overwatch are gone. You'd think that 550 watt would be enough for a config like this, right?

0 Likes
atmosphere
Adept III

Re: Constant micro stuttering on RX 480 w 3700X during games

Could you try removing the drivers, than reinstall without beeing connected to the internet? 

I could be that Windows tries to install its Windows update driver, or that there is a conflict with current Wagtman profile. Have you tried the recommended 19.11/.12 drivers? 

Does the problem persist?

You said the turning down the power limit seems to make things better, and that you have an 550W PSU.

First, are the GPU fans spinning? Maybe something got caugth, and the GPU gets hot so quick it cant reach higher powerstates. After that quick check make sure you use PCIE power connector straight from PSU, or if you use a Molex    converter make sure its a free cable, and no other appliances use it. You also could try to reset powerlimit and try undervolting the CPU. The TDP of Ryzen is not powerdraw... and especially when boosting.

Lower voltage and clocks will result in less  powerdraw: more cleaner power for the GPU. 

550Watt should be enough but not all PSU’s are equall. (And lol, most PSUs have more loadlines/rails)

if possible post a screenshot of Wattman graph,.. maybe it shows throtteling or temp limit ..  

Anyway you have a new system, do you also have a new mobo?

Lol, 570 so its new... First of all try to set the pcie slot to Gen3 if you can... 

mischaw
Adept I

Re: Constant micro stuttering on RX 480 w 3700X during games

Wow, thanks for all the info, very much appreciated! 

GPU fans are indeed spinning and I do use a direct PCIE power connector.

I found this topic on Techpowerup forums: What is happening with my GPU? (Radeon rx480) | Page 3 | TechPowerUp Forums and it turns out I had the same problem. After reapplying thermal paste the GPU runs much better. I still get the occasional movement lag, but no frame stutter. At -15% power the lag movement is gone too. I will try installing thesuggested drivers to see if I can run it stable at no power reduction. Also I will try setting the PCIE slot to gen 3, didn't know that was possible.

Once again, thanks loads!