Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Constant crashes in and out of games.

Hello guys! I have had a Gigabyte Radeon R9 380 and recently I've been experiencing some issues. During games, or even being on chrome for that matter, I get an error saying "Application <insert game title here> has been blocked from accessing graphics hardware." I then realise that my Radeon settings software has crashed and have to restart it. Even then, the error persists. I've noticed this error from games like Rainbow Six Siege, to Fortnite, even Chrome isn't crash-free. I've tried reinstalling my drivers or rolling back on previous driver versions with DDU, namely 16.11 or 17.1, but no luck. Now comes the tricky part. I check the Event Viewer on my PC and find out right before any game crash error, there is the error "Display driver amdkmdap stopped responding and has successfully recovered.", with event ID 4101. I did some digging on my own, and upped the TDRdelay to 8 seconds, but no luck. I upgraded my PSU from 430 to 550 Watts, still getting crashes. Tried downvolting the card by a small amount, that makes the system kinda stable, but not entirely. Finally I decided to bump the TDRdelay to 16, and it seems mostly stable. I was curious if you guys had any solutions to this, or any other things I haven't tried, I'd love to hear from you and have this issue finally resolved.

Thank you for reading, and have a nice day!

16 Replies

Also some more system specs may help someone offer further suggestions.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..

Yes of course, my bad. The specs are:

Computer Type: Custom made desktop

GPU: GV-R938WF2-4GD (Gigabyte R9 380)

CPU: Ryzen 3 1200

Motherboard: Asrock AB-350m

Ram: 2x4GB

HDD: Western Digital Caviar Blue 1TB

PSU: Corsair CX 550M

Driver version: currently on 18.4.1


Your PSU is the minimum PSU Wattage needed to run your computer system with a R9 380 GPU card. According to this website: PSU REQUIREMENTS - RealHardTechX .

Edit: 05/24/2018 - posted wrong link. correct link posted now.

But it should still run your computer.

ASrock Motherboard has some new BIOS and AMD CHIPSET that you should update if you haven't yet. Updating these will help make your CPU and RAM Memory and AMD Drivers more compatible to the motherboard: ASRock > AB350M . If this isn't the exact model go then go to ASrock support and locate your motherboard. I imagine the CHIPSET and possibly the BIOS would be the same.

For Windows 10:

BIOS - version 4.60 - 05/10/2018

AMD AIO DRIVER - 04/25/2018


I'm not too damiliar with bios flashing, can you help me out a bit? Cause from what I deducted it's a very risky process


In the past it was very risky to update the motherboard's BIOS. There still is risk in doing it now a days. But download and use your Motherboard's latest BIOS Update software to update the BIOS. It is fairly easy in today's modern Motherboards. The most important factor in updating the BIOS is once the BIOS starts the actual updating, IT CAN'T BE INTERRUPTED IN ANY WAYS, through a power loss or some other reason. It is best to update the BIOS thru BIOS itself using the motherboard's BIOS updating software. You can update the BIOS through Windows but it is riskier. Since you never know what program installed could cause Windows to crash or interfere with the BIOS update.

Here is the Manual for the ASrock AB350m Motherboard unless you have a different AB350 board. There are several versions. Need to make sure you have the correct Motherboard version BIOS by googling your exact MAKE AND MODEL motherboard and then going to support to see what version of BIOS they have. Here is the PDF manual which explains how to update the BIOS on your  motherboard using their own software:​.

This is a picture from the link about updating the BIOS on the AB350m Motherboard:


I checked what BIOS version I have using Command Prompt and it seems like I have a really outdated version, specifically SMBIOS version P1.20. Do you know which updates I should download first, or what updates in what order?


Google your EXACT MAKE & MODEL of your ASrock Motherboard if it isn't the AB350m. The AB350m has several versions of your motherboard. Once you go to ASrock Support for your exact Motherboard version, go to BIOS and see what the latest version is. It will indicate whether you need to update the current version to another version before updating to the latest version.

Download the Manual for your Motherboard and follow the instructions on how to update the BIOS or search under Youtube to visually see how to update your motherboard's BIOS.

Download a free program called SPECCY. It will tell you the BIOS Version you have installed plus the MAKE & MODEL of several of your major components like GPU and Motherboard and CPU/APU.


I do have the 350m. So I just flash the 3.20 and 4.60 versions in that order right?


before updating your BIOS, follow these tips on how to resolve your Error first as per this link: [Solved] Application has been blocked from accessing Graphics hardware Windows 10 - Driver Easy  or this link which give better tips : Fix: Application has been blocked from accessing graphics hardware - .

This from AMD Support about the AMD Error: How to troubleshoot “Display driver stopped responding and has recovered”, ATIKMDAG.sys type errors and from AMD Forums : Graphics driver stopped responding and has recovered....TDR fix and here also : How to Fix “Display driver stopped responding and has recovered” Error on Windows?

Try all these troubleshooting fixes BEFORE updating your BIOS. It sounds like a software problem so far.



Sadly I've tried everything these articles say, to no avail


If you tried all that. Then maybe updating your BIOS might help. It is no guarantee though.

You mentioned that you have BIOS version 1.2 installed. But according to ASrock Support the original BIOS version for the AB350m is version 2.0. So please verify your BIOS version either by booting into BIOS or using SPECCY to make sure of the version you have installed. Make double sure your Motherboard is just the AB350m and not something like the AB350m PRO 4 or the AB350m PRO4/DASH or AB350m - HDV. Each may have a slightly different BIOS version.

Anyways, According to ASrock Support, if you have BIOS version earlier than v3.20 than you must first update the BIOS to version 3.2 than update again to the latest Version BIOS which for the AB350m is version 4.60.

Be sure to download your motherboard's manual and follow the steps on how to update the BIOS or google it to see if there is a Youtube video you can watch on how to update your ASrock motherboard's BIOS.

If after updating your BIOS and you still have the same problem. I would suggest an Ingrade Repair for your Windows system. This is basically reinstalling the same version Windows on top of the same WIndows you have installed. You will need a copy of WIndows .ISO file to make a USB able to install or an external Hard drive to be able to install. I would suggest using Windows Media Creation tool to make a USB installation drive or extract the .ISO file to an external Hard Drive and then click on setup.


MB.JPGAs you can see, it is indeed Version P1.20. I should proceed with version P3.20 and move on to P4.60 then?


You must of bought the very first version (1.0) of the AB350m Motherboard. At ASrock Support the earliest it shows is Version 2.0 - 03/30/2017.

Yes, Update first to version 3.20. See if that makes any difference. If not then updated to the latest version 4.60.

How is how to use INSTANT FLASH by ASrock Support: ASRock - BIOS Upgrade Instruction Guide . Read this and follow it closely so that you won't make a mistake.


Updated to version 4.60, still getting crashes. Could it be TDRdelay? When I had it set to 8 it threw me out of games and sent a notification saying "application <...> has been blocked from accessing graphics hardware", now set at 16 the screen just flashes to black and the system freezes for like 5 seconds. I still hope that the problem is due to software not hardware but at this point I do not know what to assume.


Run "SFC /scannow" in a elevated Command Prompt and be sure it comes back as no integrity seen or something like that.

Then run MEMTEST86 for about two passes to make sure there are no errors. You can download it and install it on a USB Flash drive. it is free.

Put your TDR back to 8 seconds in the Registry.

Install the latest AMD Driver for the R9 380 GPU Card: Desktop


Still getting errors