Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Blender and Games crashes RX6600M (squares artifacts)

I have a problem with my new laptop. When working in Blender the system freezes after some minutes and artefacts (small squares) show up on the screen.

My first thought was that it's Blender's fault. But the same thing happens when I play games.

It's not the case of system overload or overheating either because the problem occurs even when I do the simplest things in Blender.

At some point when I play, the game freezes and artefacts show up on the screen - and the game doesn't respond and I have to swith it off via Task Manager. And waiting for it to respond doesn't do any good. At the same time the rest of programes and apps open in the background work perfectly fine.

My laptop is Omen 16 c0322nw
ryzen 7 5800H
AMD Radeon RX 6600m
16 Gb ram
Win 11 

I have the most up-to-date dreivers (22.2.3) and I've already tried the old drivers - no changes. Windows System has all the updates. The problem doesn't depend on whether the laptop is plugged or not.

I've updated the Bios' drivers and tried to run the programes in backwards compatibility mode and as Administrator. Then I've reset the entire system back to the factory settings - nothing's changed. The problem still occurs.

I've played Hearts of Iron 4, Batlle Brothers and Kingdom Come Deliverance and the problem's occured only with Hearts of Iron 4 and Batlle Brothers (which have less requirements in theory). Kingdom Come's worked perfectly fine.

Do you guys have any ideas what could be the nature of problem? Bez tytułu.jpg

46 Replies

Did you tried to use amdgpu.aspm=0 or amdgpu.dpm=0?(Linux)

Or pcie energy saving to maximum performance(off energy savings) in powercfg.cpl.

It seem that devs think if it fail with minority cases than it is faulty hardware.

I think the same if devs that selling this think like that then you just need to do RMA. Only money will change their thinking.

 Already got my motherboard replaced, but then maybe they put back the old one in the laptop by accident. Don't even know if it's possible to check as there seem to be a kind of tag to be done when they are replaced. Lenovo only send 1 stick of ram instead of 2 as even if my laptop was sold with 2 it's not a kit as they say, so only one was replaced and the problem is still here. Since last week my charger died on me, for no reason, now waiting for a new one. This laptop is killing me, and don't have the money to send it back to the store I bought it from for now. I just don't know how I have so many problem with this laptop, my old Lenovo laptop that is like 5 years old no is still alive and kicking if we don't account the battery that weared down wich is perfectly normal (not a gaming laptop but still). If I knew I wouldn't have brought a laptop but a overpriced graphic card that would have made my desktop a war machine and would have costed less money, just why did I thought of changing laptop to solve the battery issue of the old one, my student brain was dumb


It seems like you're right, in Windows 11, I just changed 2 values under:


You have to search corresponding folder, (e.g. 0000, etc.) There's EnableAspmL0s and EnableAspmL1, set them to 0

I don't see crashes anymore. Note, I have the latest driver which is 31.0.12029.4013 (taken from here: the latest one)

Looks like AMD fixed the driver, but for me there are some issues still if it this is set to 1.

P.S.: I will be testing it during these day. If someone else can do this as well, that will help a lot!


@Konst Unfortunately, the problem does not reproduce on a large number of equipment, so the developers will ignore us and do nothing to solve it.

You can ask Lenovo to add ASPM option to BIOS. Asrock for example provided me with such in 2 days.


This works for me! 

Thank you so much! 
I do hope AMD and HP take notes from you. It is unfortunate to see many people on a forum with no budget or time to resolve an issue that I am sure many people experience and turn away from brands like HP and AMD. 

Journeyman III

I experience the same issue as described above, and Konst's fix resolves it. Whilst I appreciate all the hard work Konst has done, it's obvious that there's an issue with the display driver. Is there a way to escalate this?

Journeyman III

Why does AMD and HP not fix this???
Trying the app for a few hours, so far so good.
I will email AMD!