cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

ashton_p
Adept I
Adept I

ATI Radeon 5870 not detecting.

Jump to solution

Hello! Thanks in advance for any help.

MY ATI Radeon that I fount in my old workstation is not being detected by windows. Well, it is, just hidden by device manager. I've tried installing the drivers and multiple solutions however, it still is hidden. I know it works due to every time I uninstall it, it re installs it. I've tried everything PCI related in the bios and I know the lane works. I will list my system info below. Thanks once again!

---My System---

OS: Windows 10  Education (Dad works at collage, got it really cheap.)

CPU: Ryzen 3 2200G

GPU 1: Vega 8

GPU 2: ATI Radeon 5870

PSU: Thermaltake Smart 600 Series

Motherboard: Asus Tuf Gaming B350 Gaming-Plus M-ATX

Drive 1: 250 Gig WD drive

Drive 2: 1TB Barracuda Drive

Don't mind my crap system, trying to get a 1080TI and servers.

0 Kudos
1 Solution

Accepted Solutions
ashton_p
Adept I
Adept I

Re: ATI Radeon 5870 not detecting.

Jump to solution

---Update---

Now I have concluded that the pcb is not making a proper connection.

View solution in original post

0 Kudos
2 Replies
ashton_p
Adept I
Adept I

Re: ATI Radeon 5870 not detecting.

Jump to solution

I have now reached the point to where the driver stops installing.

0 Kudos
ashton_p
Adept I
Adept I

Re: ATI Radeon 5870 not detecting.

Jump to solution

---Update---

Now I have concluded that the pcb is not making a proper connection.

View solution in original post

0 Kudos