Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Anyone using oculus link Quest 2 with RX 570?

I have a Quest 2 and I'm using oculus link with the official cable and an RX 570 GPU, but my PC has been freezing/crashing.

Does anyone also have an RX 570 GPU and uses oculus link without problems?

The problem I get is when playing games or watching VR videos (I'm using the Deo VR app) my computer freezes, I get a black screen and have to restart my PC. In games it's like after 10 to 30 minutes, but with VR videos it's normally just after about 2 minutes.

I did some analysis by creating windows crash dumps with CTRL + SCROLL LOCK ( and analysing them with WinDbg, and I think there's a a timeout in GPU operations (TDR:

5 Replies
Journeyman III

Having the same issue here with the same card (RX 570) and did some testing on the Linux side to test if it was a power stability issue, but letting it run on a CPU and GPU load it was rock-steady with 100% utilization.

However on the Windows side with VRChat I can get it to crash under an hour by hanging around in modestly occupied lobbies. So I'm fearing to think it's a driver issue and unless AMD cares to fix it then I might have to consider rolling back several versions until it's stable. Not that this would be a problem since most of the games I typically play are older, but still demanding, titles.


Update: I using the recommendation on Reddit, it seems like using AMD Adrenaline 22.11.2 has been rock-steady for me while using the Oculus Rift S, even going as far as 12 hours with no issues. Though I could recommend using a Type-C to USB 3.0 adapter if your motherboard has a Type-C. It could be a EMF issue, but it seems to decrease the chances of audio getting bit-crunched and requiring to restart the Windows Audio service to fix the issue live. Using VoiceMeeter, or some other virtual patchbay with a button to restart audio, is also useful—amongst other things.


I think I tested that version, but I'm not sure. But what do you mean by following the recommendation on Reddit? it's a long thread, and the original post has been deleted, or you just mean using 22.11.2?

I also have problems with vrchat. it's like 40 minutes or one hour for my PC to freeze.

In one of my tests the EFI partition got corrupted, and my PC could no longer boot without having to go to the BIOS and selecting the right partition each time I started my PC, and I had to restore a hard drive system image from a backup to recover my PC (which took many hours), so now I'm a bit afraid to do experiments. But I don't like very much using older driver versions as they will potentially contain security vulnerabilities that could be exploited by visiting malicious websites, for example.

Several new driver versions came out recently, but I haven't tested them, but looking at the release notes I coulnd't find anything I thought that could indicate this problem has been fixed.


Oh I was citing where I got 22.11.2 recommendation from instead of blindly telling you to do something. I prefer to show where I got it so there's a chain of where the fact came from and overall transparency. Though I did word it weird so I'll fix that.

And, yeah I managed to hit a similar snag when trying to get my drivers together on a new motherboard though I wasn't touching AMD drivers at that time. I feel like it might've been a coincidence, but I don't typically have anything important on Windows (Linux daily driver here) so no tears were had when I had to pull what little I had then nuke it. I treat Windows in similar vain to like a game console now since it's easier to just nuke the whole thing instead of unearthing whatever broken thing driving me to drink hard spirits. And with Steam's Proton I'm using Windows less and less, only for niche titles, hardware, and VR.

I also looked into GPU Driver vulnerabilities and AMD does have a Security Bulletin page, but taking a read it looks like you need a program executing on the system already to elevate yourself. So a drive-by attack doesn't look likely here and you'd have to be worrying about other things like your browser or what you allow on your system before you start asking about your GPU.

Journeyman III

ok, I was unsure if it was just 22.11.2 or if there was some additional configuration, for example.

This weekend I did some tests with several driver versions, but I was able to replicate the problem still with 22.11.2. I tried the following previous versions (21.6.1, 21.10.2, 22.1.2, 22.3.1 and 22.5.1) and I wasn't able to replicate the problem in any of them, but I think this is not conclusive, as I tried the latest version and wasn't able to replicate the problem initially also, but later the problem happened again.

I don't know if I'll do much more tests, as I've already spent many hours with this. I've reported the problem again to AMD, this time including my email address, let's see if they say something.

About the security vulnerability, that bulletin was last updated 11/08/2022, so there might be additional vulverabilities that were discovered/disclosed later.